PDA

View Full Version : 2009 X2 - 350 MCX Power Loss & High Idle


j4rowell
06-03-2013, 11:18 AM
I'm in need of some help.

When the boat is under load (ie surfing/wakeboarding) the engine will cut out every so often. The boat will not stall, but just return to an idle. After shutting the boat off for about 3 -5 minutes it seems to run fine for a bit but will eventually happen again.

Another issue I am having which I'm hoping is related, is sometimes the boat will idle high/rough.

Any suggestions?

snork
06-03-2013, 11:21 AM
how many hrs?

CantRepeat
06-03-2013, 11:34 AM
I'm in need of some help.

When the boat is under load (ie surfing/wakeboarding) the engine will cut out every so often. The boat will not stall, but just return to an idle. After shutting the boat off for about 3 -5 minutes it seems to run fine for a bit but will eventually happen again.

Another issue I am having which I'm hoping is related, is sometimes the boat will idle high/rough.

Any suggestions?

When it idles back down are you getting a buzzer and a check engine on the screen? Is your oil level low?

j4rowell
06-03-2013, 11:43 AM
how many hrs?

394 Hours

When it idles back down are you getting a buzzer and a check engine on the screen? Is your oil level low?

I am getting a "Check Engine" screen when the power cuts out but when the idle issue happens there is no "Check Engine" screen.

Thanks for the questions guys! Keep them coming!

Jerseydave
06-03-2013, 11:43 AM
Assuming the oil level and oil pressure are good, and the boat is not overheating, the next thing to check is fuel pressure. If you can check it when it loses power that would be best.

Sounds like your fuel pump is failing when it gets hot, then you shut it off for a bit and it cools down enough to start working again. Don't let your fuel tank go below 1/4 ever.

j4rowell
06-03-2013, 11:46 AM
Assuming the oil level and oil pressure are good, and the boat is not overheating, the next thing to check is fuel pressure. If you can check it when it loses power that would be best.

Sounds like your fuel pump is failing when it gets hot, then you shut it off for a bit and it cools down enough to start working again. Don't let your fuel tank go below 1/4 ever.

Would the fuel pump be related to the idle issue?

CantRepeat
06-03-2013, 12:04 PM
Would the fuel pump be related to the idle issue?

Yes fuel pump/low pressure could result in a poor idle. It's a pretty easy check.

http://www.napaonline.com/Catalog/CatalogItemDetail.aspx?R=BK_7002336_0361126168

The issue with your boat, MEFI 5 ECM, is you will need a semi expensive scan tool or PC software and cable to pull the codes from it.

j4rowell
06-03-2013, 12:16 PM
Yes fuel pump/low pressure could result in a poor idle. It's a pretty easy check.

http://www.napaonline.com/Catalog/CatalogItemDetail.aspx?R=BK_7002336_0361126168

The issue with your boat, MEFI 5 ECM, is you will need a semi expensive scan tool or PC software and cable to pull the codes from it.

Great. I'll check the pressure. What's the operating range for this pump?

Can someone supply a cross reference number to the fuel pump for my motor so I can purchase from the local auto parts store (ie NAPA, AutoZone, Advance Auto, O'Reily's or Pep Boys)?

CantRepeat
06-03-2013, 12:48 PM
Great. I'll check the pressure. What's the operating range for this pump?

Can someone supply a cross reference number to the fuel pump for my motor so I can purchase from the local auto parts store (ie NAPA, AutoZone, Advance Auto, O'Reily's or Pep Boys)?

Fuel pressure should be between 55-62 from idle to WOT.

A couple of threads about fuel pumps.

http://www.mastercraft.com/teamtalk/showthread.php?t=24965

http://www.mastercraft.com/teamtalk/showthread.php?t=25783

Seano
06-05-2013, 11:53 PM
check for exhaust manifold elbow sensor update for the 2008's. I had many issues with these #$%# sensors. Perhaps your 2009 was a 2008 engine. Basically the sensors are deleted for emission as they are faulty unless you live in California off course. My boat went into limp mode at a governed rpm. I did not have the idling RPM issue. good luck