PDA

View Full Version : Carburetor question


Bluccous
05-16-2013, 07:02 PM
I have a question about the secondary side of the carb. It is a standard marine Holley 600 with electric choke. The motor is running and idling good, but the back barrels don't seem to be opening up. I have taken the rpm's to 4000 on the trailer but still not opening. Not sure what is going on . Any help appreciated!!

thatsmrmastercraft
05-16-2013, 07:17 PM
They won't open up unless the engine is under load. You won't be able to get the vacuum low enough without doing some damage to your engine. If you are suspecting that they aren't opening, you will need to do an on the water test with the engine cover open or off to see.

thatsmrmastercraft
05-16-2013, 07:18 PM
If the secondary diaphragm is bad, it won't open at all.

Bluccous
05-16-2013, 07:34 PM
I was thinking that but wanted to ask for sure. Thanks!

thatsmrmastercraft
05-16-2013, 09:59 PM
I was thinking that but wanted to ask for sure. Thanks!

No problem.......that's what this place is all about. Well, that and pictures. :rolleyes:

markismm
05-17-2013, 12:35 PM
You can make them open up manually through the use of compressed air. See this link which is helpful in diagnosing your problem in the driveway.

http://www.chevyhiperformance.com/techarticles/67822_holley_vacuum_secondary_operation/

1988prostar190
05-23-2013, 10:40 PM
also if your piont distance is off the timing will be off which doesnt give the cycle enough vacume to open the rear barrels, this was just set up von my boat. Mine was a quick fix in the rotar cap