PDA

View Full Version : Driver seat mounts


96prostar190
04-28-2013, 11:19 PM
Hey guys, so today I somehow broke the front two mounts on the drivers seat... I'm baffled. Not sure how it happened or if one was broken before and today I just finished it off or what. Anyways, has anyone had a problem like this? I'm changing the oil and doing other random stuff to it tomorrow too so I might as well fix this too! Any one have solid fixes? Thanks in advance for the help!

Miss Rita
04-29-2013, 09:26 PM
did you break the sliders, or did it break where the sliders bolt to the pedestal? If the sliders are broken then they are easily replaced by your friendly MC dealer, about $35.

96prostar190
04-29-2013, 10:29 PM
did you break the sliders, or did it break where the sliders bolt to the pedestal? If the sliders are broken then they are easily replaced by your friendly MC dealer, about $35.
Sliders are good, It looks like however they bolt to the sliders is the problem. Also, how the eff do you take the seat off the sliders? I was messing around with it for 20 minutes today and couldn't figure it out... Man I feel dumb.

Dylan
04-30-2013, 11:20 AM
Sliders are good, It looks like however they bolt to the sliders is the problem. Also, how the eff do you take the seat off the sliders? I was messing around with it for 20 minutes today and couldn't figure it out... Man I feel dumb.

Sounds like you pulled the bolts through the fiberglass base as Miss Rita suggested.

To remove:
Pull up your seat base, and you should have access to the holes by moving the seat. Off my memory, slide the seat all the way back removing the front two bolts. Then look at the two holes in the back, at the bottom of the backrest. Slide the seat forwards until you see the bolts, and remove.

96prostar190
04-30-2013, 01:58 PM
Thanks for the help, I'll post pics of what I'm dealing with later today.