PDA

View Full Version : Actuator Bracket Replacement


DoubleE7
03-18-2013, 09:35 PM
I noticed the other day that the bracket that attaches the actuator to the boat was broken. So I called up the local mastercraft dealer and had them pick up the part for me. Has anyone else had to replace this part or the actuator itself? If so, did you just cut the wire inside the hull? I've read on some other forums that's what they've done in the past but wanted to make sure this is the best approach before cutting/splicing wires. Here's a pic of the broken bracket (which can't be removed without pulling the wire to the actuator through. Any help would be greatly appreciated!

GoneBoatN
03-19-2013, 01:20 AM
Look at about post #7 and on at http://www.mastercraft.com/teamtalk/showthread.php?t=36449

DoubleE7
03-19-2013, 10:24 AM
Excellent. I knew there was a thread about this somewhere but my searching wasn't productive in finding it. Thanks for locating it and pointing it out to me. Very much appreciated!

GoneBoatN
03-19-2013, 10:31 AM
Excellent. I knew there was a thread about this somewhere but my searching wasn't productive in finding it. Thanks for locating it and pointing it out to me. Very much appreciated!

I've not had any luck using the search on the forum. I always end up finding stuff using google and directing it at teamtalk.

GoneBoatN
03-19-2013, 10:35 AM
BTW, my actuator had to be replaced because the wire got worn from rubbing on the swim platform. If I remember correctly mine had a connector but it is behind the rear panel of the port side rear storage locker so it can't be easily verified. I highly doubt in any case the dealer would have ran a new wire all the way through the boat. If one is not there, it just would make sense to add a connector.

jmw
03-19-2013, 01:06 PM
I have been all through my trim tab system due to a problem with it not showing on the VDIG and the wire will be spliced together inside the hull. Mine was on the starboard side near the front of the engine compartment. I have an installation guide that I aquired when trying to fix my problem http://mastercraft.com/teamtalk/showthread.php?t=52511but the forum wont let me upload due to size. If you want a copy or anyone for that matter send me PM with your email and I'll send it. If someone knows a work around for loading post-up, it's 4.28mb in pdf. It's pretty detailed on the entire trim tab installation and from MC.

GoneBoatN
03-19-2013, 01:12 PM
I have been all through my trim tab system due to a problem with it not showing on the VDIG and the wire will be spliced together inside the hull. Mine was on the starboard side near the front of the engine compartment. I have an installation guide that I aquired when trying to fix my problem http://mastercraft.com/teamtalk/showthread.php?t=52511but the forum wont let me upload due to size. If you want a copy or anyone for that matter send me PM with your email and I'll send it. If someone knows a work around for loading post-up, it's 4.28mb in pdf. It's pretty detailed on the entire trim tab installation and from MC.

My suggestion would be to use Dropbox. There is a free level of service that would provide plenty of space. See https://www.dropbox.com/pricing.

jmw
03-21-2013, 02:55 PM
I scanned the install doc in black & white and got it under the limit so here it is.

Grant777
06-17-2013, 11:56 AM
I have a saltwater series boat and just ordered the kit from Mastercraft. I was surprised that the upper bracket and edge extenders seem to be painted steel and not stainless? Hope they hold up in the saltwater they are about to be exposed to! When you guys got your replacement brackets were they painted black as well? Thanks, as always. Grant