PDA

View Full Version : Heat Exchanger for 2013 prostar


mybobtail
01-27-2013, 10:39 AM
hi anyone know where I can get a heat exchanger for my 2013 prostar.
I am looking for a company that would send international as I am in oz
thanks

Cloaked
01-27-2013, 10:53 AM
hi anyone know where I can get a heat exchanger for my 2013 prostar.
I am looking for a company that would send international as I am in oz
thanks
What engine?

mybobtail
01-27-2013, 10:59 AM
5.7 illmor

Cloaked
01-27-2013, 01:35 PM
I'll call two places tomorrow Mon Jan 28 (eastern time zone) and see if they can assist.

Jim@BAWS
01-27-2013, 05:02 PM
hi anyone know where I can get a heat exchanger for my 2013 prostar.
I am looking for a company that would send international as I am in oz
thanks

My suggestion would be to contact a MasterCraft dealer with your engine serial #
and get the correct heat exchange unit from a dealer. ILMOR does marinize for saltwater
use. You need to consider your exhaust manifolds also

Jim@BAWS

mybobtail
01-27-2013, 10:07 PM
I'll call two places tomorrow Mon Jan 28 (eastern time zone) and see if they can assist.

hey thanks a lot cloak

mybobtail
01-27-2013, 10:10 PM
hey jim
my dealer here said see if i could get one sent over from usa as it would be a lot cheaper for me and then he would fit it . my boat seems to run hot closer to 190 all the time.
mainly want to try and keep it cooler boat doesnt run in saltwater

petermegan
01-28-2013, 04:24 AM
hey jim
my dealer here said see if i could get one sent over from usa as it would be a lot cheaper for me and then he would fit it . my boat seems to run hot closer to 190 all the time.
mainly want to try and keep it cooler boat doesnt run in saltwater

Now you have me confused?? How is fitting the heat exchanger going to make it run cooler? You were buying a new boat last time I heard, isn't it under warranty? Just seems a little bizarre. Tell us more.

AussieMC
01-28-2013, 05:59 AM
hey jim
my dealer here said see if i could get one sent over from usa as it would be a lot cheaper for me and then he would fit it . my boat seems to run hot closer to 190 all the time.
mainly want to try and keep it cooler boat doesnt run in saltwater

We (our ski club) are currently skiing behind a 2013 6.0lt saltwater series ilmor, with heat exchanger (in salt water), and it runs at or very close to 190F all the time.

FourFourty
01-28-2013, 08:49 AM
I think these new boats are supposed to be running between 180-200 all the time. (Emissions Related)

mybobtail
01-28-2013, 10:03 AM
ok i try and explain . the boat is new only 48 hrs. i have already gone through an impeller that went the second time i took it. i always slighty turn the key to make sure have battery charge.i did put a post up in regards to that. all i can say is the boat never actaully started. but i will take the blame for the impeller the dealer did cover it though. the boat seems to run closer to 190 and the odd 200 and then sometimes it goes as low as 170. i was told by putting on a heat exchanger it will help keep the temp more constant. then someone else said there mainly used so you dont run saltwater through your motor. my X14 had the heat exchanger. but i must admit i never watched the temp guage as much as i do in the prostar.mainly because of what happened with the impeller i am always checking . maybe i am being paranoid

AussieMC
01-28-2013, 04:28 PM
I think these new boats are supposed to be running between 180-200 all the time. (Emissions Related)

I agree. The owner of the 2013 we ski behind is always commenting (being cautious, not paranoid) about the temp as well, and as stated previously, it runs a heat exchanger.

bcd
01-28-2013, 04:40 PM
New boats get a 190 deg thermostat. It will jump around a little, sometimes breaking 200, sometimes dropping to 170. Putting a new or bigger heat exchanger will not make the boat run cooler because your thermostat will close when you dip under 190 degrees, which cuts off flow to the heat exchanger. What is your issue? Are you getting overheat warnings?

mybobtail
01-28-2013, 10:41 PM
hi bcd
no i am not getting any warnings. thats what my dealer said if there are no warnings it should be fine. he did mention about changing the thermostate if i wanted to. i ph him this morning and he miss understood why i wanted to put on the heat exchanger he thought i wanted to start taking boat into salt water.when i did the impeller the warning alarm came on straight away.
maybe i am just being really cautious

Cloaked
01-29-2013, 07:23 PM
Follow-up

I called two sources that I use and neither had that part in their stock. I'm still looking.

.