PDA

View Full Version : Manifold hose


CC2MC
11-26-2012, 06:52 PM
I went to show a friend of mine how to drain the water from his X-30 and when I drained the manifold, I noticed that it had a hose that connected the two manifolds together that looked like a heavy duty garden hose. All I had to do was unscrew them in the middle, which drained both manifolds.

Here is my question, which has probably already been brought up. Is there any reason I could not put a similar hose on my LT-1 manifolds? That way, there are no plugs to unscrew every winter.

KahunaCraft
11-26-2012, 07:20 PM
I know some engines have plastic balls that, I think, regulate pressure between sides of the engine. Not sure if MC has them and I don't know if you'll mess up the circulation of cooling water if you create the bypass.

Double D
11-26-2012, 08:01 PM
I added shut-offs, with hoses to the bilge, on each jacket. Found them for sale on here and bought them. One flip of two knobs and my jackets are empty.

Never hear of tieing them together. Sounds interesting...

Footin
11-26-2012, 08:15 PM
Went to Home Depot and bough 1/4 turn ball valves and screwed them in.

CC2MC
11-26-2012, 11:18 PM
Went to Home Depot and bough 1/4 turn ball valves and screwed them in.

Ball valves is an easy and cheap solution in addition to adding hoses to them to the bilge if at all possible. Are they brass ball valves?

Snipe
11-28-2012, 07:01 PM
Pictures??

CC2MC
11-29-2012, 09:16 AM
I wish I would have taken one. I am not sure when I will get back over there. I will see if I can get my buddy to take one. There is probably someone else on here that has the same thing on their X30. I believe his boat is around a 2002, give or take a couple years.

JimN
11-29-2012, 09:30 AM
Those hoses were added in '99, IIRC. AFAIK, there's nothing to balance pressure and the manifold cooling jacket isn't pressurized.

east tx skier
11-29-2012, 10:09 AM
Those hoses were added in '99, IIRC. AFAIK, there's nothing to balance pressure and the manifold cooling jacket isn't pressurized.

99 is correct. My brother in law's 99 Supra Comp has them. My father in law's 98 PS205 does not.