PDA

View Full Version : More help for a new owner: PS 197 Fuel system


Kweisner
10-04-2012, 09:36 PM
Newbie question: tried searching the forum but no luck so far. At the top of my tank there is what appears to be a connection point for a small diameter hose, but there is no hose or tubing attached. I have a photo--this outlet is peeking out just underneath the orange line. Could this just be some sort of vent? Where would the other end of the line that attaches to this go? Many thanks in advance--gas scares the hell out of me!

Kweisner
10-04-2012, 09:48 PM
Here's the missing photo!

mikeg205
10-04-2012, 09:55 PM
uh that does not look right... are you original owner???

http://www.mastercraft.com/teamtalk/showthread.php?t=25783



review this...

Kweisner
10-04-2012, 10:48 PM
I just acquired this boat a couple of weeks back. Performance is fine in every respect, but I've been going over it bit by bit to see if there's anything that needs to be fixed, replaced, refurbed, etc. I did check out that other thread, and see that the pump pictured there doesn't have this ancillary connection point. . .so I'm still stumped. I did go through about 20 pages of that post, so at least got some education on other aspects.

Thanks for the reply. . . I'll keep poking around and welcome any other guidance.

jkski
10-05-2012, 08:46 AM
I can not tell you what that specific part of the fuel pump is/does however, I can tell you that I have replaced several fuel pumps and not a single one of them had anything attached to that part, and all of my boats came direct from the factory.
Hopefully this helps in some way to help calm your nerves.

Kweisner
10-05-2012, 10:01 PM
Thanks jkski. That does calm my nerves and I appreciate the info.

Sodar
10-06-2012, 12:21 PM
What year? Just took a pic of mine and I don't have the smaller barb. Mine is an '07...

85086

Kweisner
10-07-2012, 11:44 AM
What year? Just took a pic of mine and I don't have the smaller barb. Mine is an '07...

85086

Sodar, mine is also an '07, but in reading the forum it's clear to me that the individual parts could be from any year!

ttu
10-07-2012, 12:00 PM
i have the original fuel pump assy in my garage and mine is just like sodar's. mine is a 07 also.

Thrall
10-07-2012, 12:59 PM
06 here, no extra hose barb on the FP assy either.
Possibly some sort of vent?
I'd say if it runs good and nothing leaks out of it, it is fine like it is.
DOesn't look like it's ever had a hose on it???

OP's sticker even says Mastercraft on it, so has to be OE I'd think.

mikeg205
10-07-2012, 09:19 PM
What year? Just took a pic of mine and I don't have the smaller barb. Mine is an '07...

85086

That red hose connection does just does look finished...does it. hmmmm..but i t works...:rolleyes:

jkski
10-08-2012, 08:55 AM
I think MC changed fuel pumps or the design changed at some point back when they were having a lot of issues with the in-tank design. I know the one I had in my 2002 and 2005 were just like the one you have as I had to replace both of them. In your 07, you may have an older, leftover pump or if you are not the original owner, maybe it was replaced by the previous owner with an older model.
Just some thoughts but either way I think you are fine.