PDA

View Full Version : 08 X-2 VDIG Perfect Pass & ECM Update


jddavis6
10-04-2012, 06:03 PM
Boat: 08 X-2, MCX 350, VDIG
I recently had an issue which caused a check engine alarm to come on, took boat to Indmar certified shop, turned out to be an issue with the cat temp sensor which in turn was actually an issue with the ECM version. The mechanic downloaded the new code from Indmar and flashed the ECM. The next time I took the boat out, the Perfect Pass would not engage until I was at full throttle. Contacted Indmar, they state that it does not have to do with the ECM update. Contacted Mastercraft dealer, both Seattle and Post Falls and they have no idea, nor are very helpful. Contacted Perfect Pass and they also were not helpful in that the PP is integrated into the Medallion instrument, thus they recommended me to Medallion. They have not responded to my emails yet. So, my question is: Is there any other issue / cable or termination device that I am missing? Have you guys heard of this issue? Please help.

Thanks in advance,
Jeremy:cool:

93Prostar190
10-04-2012, 06:12 PM
2008 would be drive by wire so it seems to me that based on your explanation something coming from the harness to the PP DBW module is not right ..... If the ECM is sending a slightly different signal to the PP Brains then it may explain it .... I doubt it is mechanical.

vision
10-04-2012, 09:47 PM
Had my 08 MCX reflashed last year for the same issue. Cat convertors run hotter with age and this was not accounted for in the ECM programming from Indmar. Indmar covered the cost of mine as they indicated that it was a known issue. The Indmar tech indicated that they expected most 08 MCXs will need to to have their ECM reprogrammed, likely around 400 to 500 hours.

I had no issues with my perfect pass afterwards. The reprogram simply tells the ECM to ignore the cat temp sensors. I would check the ECM connections around the Diacom connector and make sure that the connectors on the back of the PP button on your dash are clean and securely attached.

sand2snow22
10-04-2012, 10:08 PM
Had my 08 MCX reflashed last year for the same issue. Cat convertors run hotter with age and this was not accounted for in the ECM programming from Indmar. Indmar covered the cost of mine as they indicated that it was a known issue. The Indmar tech indicated that they expected most 08 MCXs will need to to have their ECM reprogrammed, likely around 400 to 500 hours.

I had no issues with my perfect pass afterwards. The reprogram simply tells the ECM to ignore the cat temp sensors. I would check the ECM connections around the Diacom connector and make sure that the connectors on the back of the PP button on your dash are clean and securely attached.

Sound advice right there! Gotta love TT

93Prostar190
10-05-2012, 08:28 AM
Was there a jumper that goes on the ecu connector for pp on a 2008 mcx? Maybe when the ecu was flashed via the connector they did not put the jumper back? I can post a pic of the jumper that I am referring to ..

jddavis6
10-05-2012, 04:04 PM
Was there a jumper that goes on the ecu connector for pp on a 2008 mcx? Maybe when the ecu was flashed via the connector they did not put the jumper back? I can post a pic of the jumper that I am referring to ..
Please post a pic of the jumper. Where the technician plugged in it looked like just a cap. Not sure what the jumper looked like.