PDA

View Full Version : Throttle lever question???


Jorski
09-19-2012, 01:43 PM
Anyone have any pics of the throttle control opened up? Mine feels like something is causing friction inside.

This is a new issue, it was butter smooth until about a month ago. It is easy to move in reverse and once you get past the the first bit in forward, so I don't think it is a cable issue.

Open to ideas and would love to see pics before I tear into it.

Thanks

thatsmrmastercraft
09-19-2012, 04:26 PM
The throttle on my boat is a little different than yours, but mine had a lot of sand mixed in with the grease. A thorough cleaning and fresh grease made mine very smooth.

nkorep2
09-19-2012, 11:50 PM
Idk if yours is different than the one I have on my 1990 prostar, but its a pretty simple design inside. Basically 2 gears that mesh together.

https://lh3.googleusercontent.com/-1Cb7uRgYNjQ/T7m-lGzFRbI/AAAAAAAACh4/TbgZ2HwXtqg/s640/2012-05-20_21-17-10_3.jpg

https://lh4.googleusercontent.com/-9F3z5iW-cME/T7m_auJU_UI/AAAAAAAACiI/YsBpMVmdDwo/s640/2012-05-20_21-16-55_287.jpg

https://lh5.googleusercontent.com/-0Q8t0Q5HWoo/T7m-NvStCHI/AAAAAAAAChw/joNpnMmPnS4/s640/2012-05-20_21-18-28_225.jpg

Its an easy fix.

Before
https://lh3.googleusercontent.com/-2V1h7c427eU/T7lkEX2sQRI/AAAAAAAACfA/aAwVkk9lZF0/s640/2012-05-20_17-23-32_145.jpg

After
https://lh6.googleusercontent.com/-qqEAjUSbS-E/T78JCl7svaI/AAAAAAAACoU/6OjU6Z_Ql1A/s640/2012-05-24_22-54-14_593.jpg

CC2MC
09-20-2012, 12:03 AM
Sounds like a cable issue to me. Perhaps some moisture has gotten to it. Has it sat for a couple weeks or so before it started doing this? I think worst case is you get a new cable, but that is just my opinion.

Jorski
09-20-2012, 01:23 PM
Perfect...thanks.