View Full Version : Boat won't stay running

09-15-2012, 04:49 PM
I just pulled my boat out after being gone for 3 months. 1985 s&s. 351w. The boat ran great before I left. I drained the gas tank before I left. I just filled it up. And is started and ran good. But after a while of running on the hose. It would not idle without giving it gas. can anyone help. Thanks

09-15-2012, 05:49 PM
What did the temp gauge say? I can't go more than a minute or two on the 5 gallon bucket method with the hose tuning full blast. Might check the Carb doesn't just need cleaned. More and better ideas are sure to follow by those much wiser than me.

09-15-2012, 06:13 PM
Get some carb cleaner. Spray it in the carb. And just run the boat fluctuating the throttle.
Better yet, Bring it to the lake and run some full throttle passes.
Glad to hear you are back. We still have beautiful weather here in CA till October maybe even November.

09-16-2012, 12:09 AM
Is it running rich and blowing black smoke out the exhaust? If not, it probably has some gunk in the idle circuit and it's starving for fuel. Remove the idle mixture screws (first screw them in until they lightly seat counting the number of turns) and insert the plastic tube from carb cleaner and spray through so you can see it inside the carb. Replace the mixture screws as per the number of turns.

09-16-2012, 02:07 PM
It's running rich. But no black smoke. I will still try to pull the screw. To see what happends.

09-16-2012, 02:36 PM
Take a look down the throat of the carb right after shutting it off to see if there is fuel still flowing. You could have some debris not allowing the float to close needle and seat.

09-18-2012, 05:12 PM
It turned out to be a float problem. Thank you to everyone for the help. I love this place.

09-18-2012, 06:16 PM
Good to hear you got the problem resolved. :toast: