PDA

View Full Version : 91 Prostar 190 cranking problems


mustangboiler
08-27-2012, 01:18 PM
I have a 91 prostar 190 with roughly 950 hrs on it. I replaced the old battery before going out to the lake. After swaping out skiiers, i went to fire the boat back up, it acted like it was in gear and idled very high. When i went to turn it off, the motor shut off but was still cranking. I went to remove my battery terminal and the ground wire was smoking. i eventually got it disconnected and it shut off, but when i went to hook it back up and start it, it wouldnt turn over right away. i let it sit for about 5 or 10 minutes and finally got it to start and itran fine the rest of the day. this also happened on the old battery. Is this a starter issue?

thanks,

Adam

Bert
08-30-2012, 08:17 PM
I have a 91 prostar 190 with roughly 950 hrs on it. I replaced the old battery before going out to the lake. After swaping out skiiers, i went to fire the boat back up, it acted like it was in gear and idled very high. When i went to turn it off, the motor shut off but was still cranking. I went to remove my battery terminal and the ground wire was smoking. i eventually got it disconnected and it shut off, but when i went to hook it back up and start it, it wouldnt turn over right away. i let it sit for about 5 or 10 minutes and finally got it to start and itran fine the rest of the day. this also happened on the old battery. Is this a starter issue?

thanks,

Adam

Sounds like a starter contacts issue. Take it apart and clean it up.

thatsmrmastercraft
08-30-2012, 10:17 PM
Might be the starter solenoid. May just be the starter drive shaft built up too much crud to let the starter drive disengage.

Your starter may be toast after turning for that long, or at least in need of a rebuild.