View Full Version : X2 just shut down

08-18-2012, 11:35 AM
My X2 with a mcx just shut down while surfing yeaterday , turned the key off and it started right up , Just wierd ran fine for the rest of the day. If I take it to my dealer does it have a memory? and will he be able to go back and find a code or something?

08-18-2012, 11:57 AM
might want a fuel pump handy if you hadn't replaced it yet

08-18-2012, 12:32 PM
I have one in the glove box, never let it go below half , I only have about 140 hours on the boat hope I Don't have to change it out already

08-18-2012, 12:38 PM
If you never let it run below 1/2 you probably don't have a fuel pump issue. I have 270 hours on my 11 and no problem with fuel pun. I had a 03 X30 with 750 hours and I never changed the fuel pump. Just never ran the tank below 1/4.

08-18-2012, 12:53 PM
Is it possible that the fuel tank vent was below the water? That would not only cause negative pressure in the tank, but it would also put water in the gas.

08-18-2012, 01:01 PM
We were surfing at the time , I never had it happen before , boat had 3/4 of a tank . Maybe it was just a blip . ran fine the rest of the day

08-31-2012, 08:27 AM
I think Him had an interesting theory. How much weight and how low in the water was the boat?

08-31-2012, 12:45 PM
I had that happen a few times, but then I found out that the due to the way I was sitting and turning my body when pulling surfers, my knee would hit the lanyard connection enough to shut down the boat.:o

08-31-2012, 02:57 PM
I've had stalling trouble with my MCX running at slow speed. I run the blower now, almost all the time, and haven't had any more trouble.

08-31-2012, 03:32 PM
No fuel tank vent to flood or get underwater.
If it started right up, no hesitation and continued to run fine I would suspect that you bumped the tether kill switch.
It's in a bad spot right above the cupholder. I got tired of killing the boat by accidentally bumping the tether and disconnected it.

08-31-2012, 03:57 PM
No I was no where near it , it just shut down , I'm going to bring it to the dealer tosee if there is a code or some knid of history of codes

09-01-2012, 12:53 PM
You may want to feel your fuel pump relay and see if it is getting hot maybe a bad connection at the relay, although I am puzzled it just came back online without issue on the next crank.....