PDA

View Full Version : sensor trivia time!


oshkarmeyer
08-12-2012, 03:05 PM
As I am brand new to this boat I come across little pesky sensors that I don't know the identity of. So I snapped a few pics to see if you guys could asisst.

Pic #1....I'm guessing this is an oil pressure sending unit, but where do both wires go to?

Pic #2....Is this the ECM?

Pic #3....Is the front sensor a 2nd coolant temp sensor? And what is the one in the background with the blue connector going to it?

Pic #4....This goes into the block down by the starter but I'm unsure what it is.

The boat and engine is a 2001 Prostar 205V with 5.7 TBI.

Thanks guys.

d36yzrider
08-12-2012, 03:11 PM
your right on most of them the wire next to the oil sending unit is a loose one I think I have a friend who has a newer ski centurion and it has the same thing just a loose wire the factory didnt need I think the bottom one on the block is a engine temp sensor for the ecm and the other temp sensor on the manifold is for the water temp gauge

j.mccreight@hotmail.com
08-12-2012, 03:13 PM
#1 need wiring diagram
#2 yes
#3 one goes to gauge other goes to ecm
#4 knock sensor

oshkarmeyer
08-12-2012, 03:34 PM
Ok well that's a good start, thanks for the quick replies.

As far as the oil pressure sending unit-which wire should be hooked up to it? The brown one that is currently disconnected or the blue one that is? As of right now my oil gauge will bounce between 40 and 80 the whole time I'm on the water so I figured something was up.

Maybe someone with the same engine can take a glance at theirs and see which is connected.