PDA

View Full Version : Depth, Water, Air Temp???


NatesGr8
07-25-2012, 04:16 PM
Hey guys,
This problem has been bothering me for some time and i figure its time to get it straightened out. I have an 05 X-45. I'm not getting readings from my depth or water temp displays. I've always assumed this was because the PO didn't order the boat with those options. Air temp seems correct.

My question is, was it possible to get an 05 without depth or water temp readings? If so how do i go about adding them on? Anyone out there with any ideas or who has done this please let me know. I'd like to be able to tap into the factory readout on the dash.

Thanks, Nate

macattack
07-25-2012, 06:40 PM
Pretty sure all the boats around your year are wired for these options...check the wiring bundles behind your kick panel in front of the driver's seat. The wires are labeled which will confirm your boat has the capability for these options.

Look at the top of your AIRMAR paddlewheel or model number and it should tell you whether you have the water temp feature. The water temp comes from the paddlewheel housing and it is not uncommon for this to go bad; unfortunatley, it is not fixable, so you have to buy a new paddlewheel/housing which a lot of us have done.

Air temp and depth finder are separate options, you just need to look around to see if these parts are installed in your boat. If they are, then we can start troubleshooting or you need to purchase them.

I provided some pics of each these options...hope this helps, mac

WTRSK1R
07-25-2012, 09:44 PM
I added the depth gauge to my 2004 and the air temp was part of the module for depth, so I think if you have air temp, you should have depth too. Water temp was standard on my 2004. if the can find the module macattack showed in his photo, you will be able to tell if you have the depth puck connected.

Steve

NatesGr8
07-26-2012, 08:57 AM
Thanks guys. I will do some digging today. However I'm fairly certain I don't have a depth transducer. Would it be as simple as buying the ducer and installing it and running wire to the correct connectors?

DoubleE
08-16-2012, 10:36 AM
Thanks for the great pics macattack!

Water temp:
I'm finding my water temp always shows in high 70s, no matter if its April or August. Is that the typical experience for others when they go bad?

I was looking forward to having the water temp in this boat, but not sure its worth the $160+ I was quoted for a new AIRMAR unit.

Is there really nothing we can do like clean a contact or something to try to get it more accurate again?

Depth:
My depth has been showing 400.00 or flashing an obviously wrong depth for an extended period of time after I first start up. I've tried to find any instructions in the manual or online on how to configure/calibrate/reset the puppy, but I'm not coming up with anything? I was thinking I was just try and calibrate it or something to build my confidence in her accuracy. Any ideas on where to look or what to try?

With macattacks pic of the depth module, I'll for sure check the connections for starters.