PDA

View Full Version : Need Help! Problems with Engine


Jaakko K
07-25-2012, 12:55 PM
Hi

I have x30 2007 with 350 engine. When I try to start my boat it only runs 30 or something seconds proberly and then dies. It doesnt matter if the rpm are high or not. And if I try to start it straight a way it wount start or it is realy hard but if I try after 5 min it runs smoothly 30 and then dies.

I just changed our alternator and after that it run smoothly. We ha less than half tank fuel.

I was thinking that maybe the problem is in the fuel pump but I can hear some noise and shacking when I put the power on.

Any ideas guys any help would be much appreciated.

Jaakko

MASTIQUE
07-25-2012, 01:23 PM
Another fuel pump!


Sent from my iPhone 4S using Tapatalk 2

willyt
07-25-2012, 02:34 PM
any check engine alarms?

1. check fuel pressure. 2. check voltage

ntidsl
07-25-2012, 02:47 PM
use search feature on top of page and you'll come up with the solutions...too many variables to answer...but Willy T is correct...you must check things out...check the furl pressure...search and you'll find out how to do that. good luck!

Jaakko K
07-25-2012, 02:59 PM
How can I check the fuel pressure

Jaakko K
07-26-2012, 09:01 AM
Our local dealer thinks it might be fuel pump relay or fuse can someone tell me where can I find it?

Thanks

Jaakko

willyt
07-26-2012, 01:07 PM
check out threads by HOT-4-TEACHER or 93prostar190

JimN
07-26-2012, 01:36 PM
Our local dealer thinks it might be fuel pump relay or fuse can someone tell me where can I find it?

Thanks

Jaakko

The relays and fuses should be at the rear of the engine, fairly close to the ECM (brain). Do you know what a Bosch relay looks like? That's what you need to look for.