PDA

View Full Version : 2012 X30 leaking water


Double
07-23-2012, 12:21 PM
My 2012 X30 with 60 hours is leaking water from what looks like the water pump housing. Back to dealer again tomorrow. Any else seeing this issue?

Scott
07-23-2012, 02:02 PM
not yet..

Lucky26
07-23-2012, 03:09 PM
raw water or water circulating pump?

Lucky26
07-23-2012, 03:11 PM
My raw water pump ( impeller) housing fell completely off the block. You better check every fastener on that engine.

Double
07-25-2012, 09:57 AM
water circulating pump, picked up by dealer yesterday. Haven't heard back from them yet

sand2snow22
07-25-2012, 10:12 AM
I heard they made a bad batch of cast water pumps that are prone to failure. Not an Ilmore problem but a problem across the board :(

scott023
07-25-2012, 10:25 AM
I heard they made a bad batch of cast water pumps that are prone to failure. Not an Ilmore problem but a problem across the board :(

That's brutal luck...

Double
07-25-2012, 05:02 PM
they replaced circulating pump and said boat is ready for pickup. I'll get more info and post after I pickup boat

Specter
07-25-2012, 06:49 PM
Our 2012 X30 had its circulating pump replaced before we ever took delivery. My understanding is that GM (or whoever manufacturers them) placed a recall on a certain batch and many of the boats made in early spring of this year were equipped them. Ours overheated during a test run which led them to the problem pump. Good luck with yours, hope all is fixed and ready to go.

Double
07-26-2012, 09:21 AM
all is fixed and Specter stated exactly what I heard was a GM manufacturing issue on the pump. I'm not sure why my dealership didn't take a proactive approach if there was a recall but none the less it's now fixed and I only lost one day on the water.

Lucky26
07-26-2012, 12:07 PM
Man I wish I knew the batch numbers. I have not had any problem with mine as of yet, but the way things are going I might want to get it changed.