PDA

View Full Version : Fuel Pump


wakedoc
07-22-2012, 06:51 AM
Well, it finally bit me - after almost 4 years, 400 hours (only this few as the boat has been out of action for some time trying to chase a ghost (vibration that we still haven't isolated)), my fuel pump is finally kaput.

My wife is gutted as it happened on a weekend when I was working and she had the boat out with our friends, riding for most of the day - 'hmm, running low on fuel, but the water's too good to come in - just one last ride .....'. It shut down on her just back at the ramp, so she assumed it had run out. Filled up back at home, went out this weekend and wouldn't fire up (checked pressure at the fuel rail - nada). So she is horrified that she 'killed' the boat (I told her that it was just as likely I would have done this).

So there have been several posts about the lesser likelihood of this happening in later model (post '07) boats by running under 1/4 tank. Just to let everyone know, it can still occur in an '09 X1 (MCX). I used to be paranoid about running it under 1/4 tank, but have relaxed a bit in the last year or two (haven't run it out though, until my wife did it the other day).

Any ideas on a 'better' fix for this (obviously will replace the pump module) to stop it happening again (apart from not running under 1/4 tank 8p).

BTW - she said it was an awesome last ride that day!!!

Now ............ if I can only fix that vibration ..............

Gert
07-26-2012, 04:38 AM
So there have been several posts about the lesser likelihood of this happening in later model (post '07) boats by running under 1/4 tank. Just to let everyone know, it can still occur in an '09 X1 (MCX). I used to be paranoid about running it under 1/4 tank, but have relaxed a bit in the last year or two (haven't run it out though, until my wife did it the other day).

Any ideas on a 'better' fix for this (obviously will replace the pump module) to stop it happening again (apart from not running under 1/4 tank 8p).
Made my own system some years ago. No problems, still going strong. Tank has been under 1/4 more than often:

http://www.mastercraft.com/teamtalk/showpost.php?p=758055&postcount=19

Thrall
07-26-2012, 11:28 AM
70hrs is much lower than avg (but sounds like your boat is jinxed anyway:o).
You don't need to buy the whole module. You can get just the pump at an auto parts store for <$100.
Then you should be good for another 3-400hrs.

wakedoc
07-28-2012, 06:05 AM
Thanks Gert - looks interesting.

Thrall - was at 396 hours (not 70), so at the upper end of the average hours. But yes, there is some discussion about the 'possessed' nature of my boat - although the fuel pump was not on the agenda for an unusual problem, unlike everything else! We have just replaced the pump (not the entire module) with a generic pump (it appears that these may last a little bit longer than the OEM).
Thanks for the replies!