PDA

View Full Version : Need help check eng/after fuel pump change


REDX2
07-08-2012, 03:46 PM
Ok I have an 07 X2 that I just had to change the fuel pump, ended up using the Airtex E2044 pump.
Boat starts and runs fine but I now have a Check Eng coming on the dash and an alarm is going off when check eng comes on.
Boat still runs fine when it comes on but on top of the check eng and alarm the stereo shuts off after check eng comes on.
What could this be

ttu
07-08-2012, 03:53 PM
have you tried three warm up then cool downs. it's suppose to clear the codes.

Will
07-08-2012, 03:54 PM
The computer shuts the power off to the stereo to make sure the alarm is heard. Not sure why the alarm is sounding.

REDX2
07-08-2012, 04:00 PM
Is there any way to check codes or clear them

mastercraft210
07-08-2012, 05:13 PM
Try to messure the fuelpressure.I had it on a 2009 xstar with a aftermarket pump and this wann gave a check engine because it had to less pressure.This should be at least 58 psi.

REDX2
07-08-2012, 05:30 PM
ok I can do that, what after market pump did you end up using

TN X-45
07-08-2012, 07:34 PM
RED, I used the airtex and it works great. You need 3 warm up and cool down cycles. I didnt have the stereo issue though, not sure on that. Also, I didnt hear and alarm, just the red check engine signal on the VDIG.

mastercraft210
07-09-2012, 04:38 AM
I ended up with a simple european car pump wich looks excacly the same.The fuelpressure is a little bit higher but for now no problems .