PDA

View Full Version : 93 prostar idles rough when engine is warmed up


Fusionator5
07-06-2012, 09:19 PM
I have a 93 prostar 190, with a 351 ford indmar . After it has been ran it idles very rough, rpm's surge up and down, and sometimes stalls. Also spits and sputters when you hit it to pull someone up. Runs fine when it's up on top. Carb issue?

JimN
07-06-2012, 09:31 PM
How old are the cap, rotor, plugs, wires and points? When was the last time you changed the fuel filter?

Fusionator5
07-06-2012, 09:43 PM
Bought it at the end of last season. The guy I got it from said the where replaced but who knows if he did everything

Fusionator5
07-06-2012, 10:06 PM
I'm leaning more towards something fuel related because when it stalls I have to pump it a little to fire it up again. Also the exhaust smells rich.

Jerseydave
07-06-2012, 10:10 PM
Just a thought, but when it's warmed up and has a rough idle remove the spark arrestor and look down the carb.....is it dripping gas into the venturi at idle? If so, you could have a sticky float or high float level in the carb.
I know many guys on here have replaced or rebuilt their carb, maybe yours needs a rebuild?

You could try adjusting the float level to see if that helps.

Fusionator5
07-06-2012, 10:20 PM
I will check it tomorrow . Thanks

tockit
07-06-2012, 10:24 PM
I have a 93 prostar 190, with a 351 ford indmar . After it has been ran it idles very rough, rpm's surge up and down, and sometimes stalls. Also spits and sputters when you hit it to pull someone up. Runs fine when it's up on top. Carb issue?Have you tried adjusting your idle mixture?
Start with 1-1/2 turns out on the screws on the each side of your primary bowl as a baseline and fine tune from there. Idle mixture could be rich.

Double D
07-06-2012, 10:31 PM
I have a 93 prostar 190, with a 351 ford indmar . After it has been ran it idles very rough, rpm's surge up and down, and sometimes stalls. Also spits and sputters when you hit it to pull someone up. Runs fine when it's up on top. Carb issue?

Its not a throttle body fuel injection is it?

93Prostar190
07-06-2012, 10:54 PM
Running rich?

Fusionator5
07-07-2012, 08:06 AM
It's not injected

Creeklife
07-07-2012, 09:41 AM
I have a 91 with the 351W and am having some similar problems as well. I got gas yesterday and took the wife to dinner. After a 40 minute run back to the house, I dropped it to idle to put it on the lift it was idling very low. I turned it off, let it sit and started it back up and it was still idling very low (300-400) and the exhaust smelt rich. I've been out there this morning working on it and adjusting idle mixture. Fixes the low idle but still smells rich.

JimN
07-07-2012, 10:38 AM
I'm leaning more towards something fuel related because when it stalls I have to pump it a little to fire it up again. Also the exhaust smells rich.

Does is always smell rich, or just after you get it to start? You did pump the throttle, after all.

After shutting it off, pull the flame arrestor and look into the carb- is it dripping? If so, the float may be leaking. If the carb is all original, the needle valves and seats may be gummed up, worn, whatever.

Is anyone verifying their timing when they have problems, or are they just assuming it's an idle screw adjustment issue, with no way of going back to the original setting? How clean is the flame arrestor? How old is the fuel filter and/or fuel/water separator? Has anyone looked at their fuel pickup in the tank?

Creeklife
07-07-2012, 11:05 AM
Just ran it for about 15 minutes and back to the house. Everything seems fine and doesn't smell to rich. Think it could have been bad gas? I pulled the flame arrestor and it isn't driping. The carb was rebuilt before I bought it 3 years ago. I've replaced just about everything over those 3 years but have never done anything to the Carb. I'll check the timing. What are your thoughts on carb cleaner?