PDA

View Full Version : 2005 X-Star auto Bilge pump not turning off...


REDLYNER
07-05-2012, 03:00 PM
Last night I loaded my X Star onto the boat lift after wakeboarding and I noticed a faint hum while putting on the cover. The red light for my aft bilge was on, but the switch was in the middle (push left to engage aft bilge, push right to engage front bilge) and there wasn't any water coming out. The switch being in the middle is set to where if water is in the bilge, it will automatically cut on until it is empty. It ran for half an hour last night while I tried to figure it out. So I eventually just turned the battery switch to off since it was 11:30pm. Also, on the black panel with the white buttons under the dash (fuse box?) the aft bilge pump white button was out more than the others. The directions say push in to reset, and I did, but nothing changed.

But now I need to fix it, any suggestions?

vision
07-06-2012, 01:59 AM
Stuck float in the pump. You can try leaning it.

quarterback X-30
07-01-2013, 05:12 PM
I just encountered the same exact problem this weekend with my X-30. I noticed a faint hum while wiping the boat down. I messed with the switch a little but it would not turn off. It ran until I finally turned the battery switch to off. Just read the post by Vision so I'm going to try cleaning the float and hopefully that works. Seems logical.

REDLYNER
07-01-2013, 05:28 PM
I actually haven't dealt with it yet..... :o


I have been turning off the battery power switch. Where do you gain access to the floats?

Jerseydave
07-01-2013, 08:10 PM
I actually haven't dealt with it yet..... :o


I have been turning off the battery power switch. Where do you gain access to the floats?

It's internal inside the bilge pump. Try tapping on it lightly while it's running.....it should stop. But to avoid future problems clean it. Hot water mixed with some dawn dish detergent should do the trick. Or simple green, spray nine, etc.

Aric'sX15
07-01-2013, 08:30 PM
i had this happen to a POS that is at my work where we rent out boats. i had to pull the wires to it, then it broke down on the lake and i had to go jump them. ended up having to replace it.

REDLYNER
07-08-2013, 12:25 PM
Where is the rear pump located? Pump finally went out on me, so when I went to check it this weekend, I wasn't able to track it down by the noise.

Jerseydave
07-08-2013, 12:54 PM
Where is the rear pump located? Pump finally went out on me, so when I went to check it this weekend, I wasn't able to track it down by the noise.

Check the bilge aft of the engine, just in front of the rudder. Did you try cleaning it yet?