PDA

View Full Version : Zero Off and Zero Response - Need Help


cincyskier
07-03-2012, 12:39 PM
Long story short.....

I am a promo driver with a 2012 PS197 and about a month ago the down button on my Zero Off stopped working. Ran through the gamit of checking, resetting everything etc, and the button is in fact dead. Luckily for me, I have still been able to slalom off it even though its stuck at 36 mph (I cannot cycle through the speeds). I also use my boat to pull practices for the UC Waterski Team, and for the past month we have had to hand drive it just so we can use the boat (makes you appreciate speed control and how spoiled we have all become). But as far as using the boat for its intended prupose of using it to pull tournaments, the boat is rendered useless. I have already missed 3 events because of ZO not working, and I have a couple more in the coming weeks that I am not too confident about making.

Both my dealership and MC have been aware of the problem since Day 1 and have been on top of it, but both they and myself, are having zero luck with Zero Off (no pun inteded) and getting any type of response from them. I understand that some things take some time to get resolved, but the fact that its been over a month and I am on the verge of missing a total of 5 events for the year is a little frustrating. And we still have no line of sight to a solution.

We are at a loss of what to do to get this resolved any faster. Any suggestions?

kyfooter
07-03-2012, 12:44 PM
You can use my boat. Perfect Pass still works!

lettmeknow
07-03-2012, 12:47 PM
If you have not done so yet, I would post this on ball of spray as well. I have heard, but do not have first hand experience, that ZO does not have best customer service. I would think getting this boat out to tournaments would be high priority, after all isn't that purpose of the promo program? Sorry to hear about your issues, I would be flaming PO'd by now. Good luck in getting this resolved!

ntidsl
07-03-2012, 12:50 PM
Still no luck huh? Bummer? So it wasn't just the button? I have no advise except Balls of Spray as mentioned above. Good luck!

cincyskier
07-03-2012, 12:56 PM
Still no luck huh? Bummer? So it wasn't just the button? I have no advise except Balls of Spray as mentioned above. Good luck!

It is just the button, but from what the dealer was able to get from ZO is the entire unit has to be ordered...cant just get the faceplate.

Sullivan
07-03-2012, 03:37 PM
Call your promo director and tell him to send you another one. I just pulled mine out and sent it back to Greg Badal to be updated. He sent one of his spares the same day I sent mine out so I was only down a day.

cincyskier
07-05-2012, 08:58 AM
Thanks for the help. I was able to get ahold of Greg Badal and he had a spare, personal unit he was going to overnight me to get me thru the time until the new one came from Zero Off. But, apparently we (dealership and I) barked up the right tree , and we actually made some headway with E-Control. Long story short, the new unit will be in the mail today. They aknowledged that there process of how dealerships order replacement parts is severely broken, and this case actually made it to the desk of their marketing manager. Hopefully....fingers crossed.... they are able to improve their issues with lackluster customer support after this. Thanks again for the help, and hopefully I will be back on the water tomorrow.

Jim@BAWS
07-05-2012, 10:30 AM
Why not order another one from MC parts and warranty it out!!!

Jim@BAWS

cincyskier
07-05-2012, 02:38 PM
Why not order another one from MC parts and warranty it out!!!

Jim@BAWS

MC could only order the entire ZO kit the way ZO's system was set up. There lay the entire issue with us not being able to just get a faceplate or any replacement parts without ordering the entire system (faceplate,controller, GPS pickups, cables, etc).