PDA

View Full Version : '93 Prostar 205 Coil


Mid TN
07-01-2012, 02:11 PM
Any one know if there is a automotive coil that fits the '93 351 Ford HO. I have had no luck at O'Reilly's, Advance or Auto Zone. Thanks!

Mid TN
07-01-2012, 04:24 PM
No Spark! The coil wire clip, on the coil, is about half gone too, but it should still fire. Guess I need to order parts!

Philscbx
07-01-2012, 04:44 PM
Take it NAPA - If they don't have it - then no one does.
When you say clip half gone - is this for high voltage main coil wire within the tower of the coil?

You can make these spark if still mounted -
Take cap off - bump motor so points just open -
With small screw driver - make & break connection across the points contact.
Coil should fire.

If it fires now - and not when cranking - sandpaper between the points - wet or dry 400-600 grit with small strips under tension of points.

Mid TN
07-01-2012, 06:05 PM
Yes it is the main coil wire for the center of the coil.

I pulled a spark plug, heald it close to the block and cranked the engine, no spark.
I believe I found it, looks to be a Prestolite coil, has some very shallow flutes down the side of it.
There are no numbers or anything on it.

Philscbx
07-01-2012, 07:16 PM
Hopefully the new works.

Mid TN
07-03-2012, 10:22 PM
Finally figured out the problem in desperation! The darn Safty Cut-Off Switch was bad! I finally bypassed it after I checked voltage across the coil, none. Cut that sucker off and twisted the wires together, taped it up and I had voltage across the coil. She fired right up! that is the second time I have had tht switch do tht to me. I was stranded in the middle of Norris lake before.

Philscbx
07-03-2012, 10:39 PM
I believe it was the reason for mystery last summer on mine once.