PDA

View Full Version : Does 2001 205V have 2 drain plugs?


Rossterman
06-20-2012, 11:40 PM
Bought a used 205v and am trying to find out if it has a center drain plug. I crawled underneath while on the trailer and didn't see one. If their is, where do you find access to it from the top and where will it be located in relation to the 3 skews?


Thanks
Ross

BrianT
06-21-2012, 12:20 AM
They only have 1 drain, unless there is a second one at the rear between the exhaust area.

jmw
06-21-2012, 12:27 AM
I had a 2000 and it had 2 plugs. 1 at the rear between exhaust and 1 in the ski locker next to the drivers seat.

Rossterman
06-21-2012, 12:37 AM
Jim- do you mean there is a drain plug through the hull in the ski locker area? I know there is a rubber stopper in the ski locker to hold water/ice as an ice chest but wanted to know if there is an additional drain plug that should be removed to drain water out when on the trailer?

Thanks!
Ross

jmw
06-21-2012, 12:43 AM
Mine had a screw in plug in the ski locker. I dont rember where it was located in relation to skegs but it must have been just in front or behind them. To be honest I do not remember a rubber plug for the ice chest, so that may have changed in 01 or someone added it.

jmw
06-21-2012, 01:01 AM
I'm certain it has a foward plug, I wonder if they stuffed a rubber plug in it for whatever reason (lost, etc...) but that would scare me without threads holding it in, probably would never come out, but if it did you probably would not realize it until water was above your floor, which would not sink you but it wouldn't be a good day... Mine had a T-handle type screw in plug. That's pretty much the only plug I used because the water seemed to flow/settle in that area. The only time the rear plug came out was to winterize and change oil...

bturner2
06-21-2012, 08:05 AM
Go under the boat and look for another hole in the bottom. That will end your mystery.

Cary K.
06-21-2012, 08:11 AM
I only have 1 on my 2001 205V. Rear brass plug on transom, none in the boat.

cav14
06-21-2012, 08:20 AM
On a 2002 X-Star (same hull) there's one at the back and one in the hull next to the fuel tank, accessible by opening the circular cover in the middle of the floor.

Rossterman
06-21-2012, 09:53 AM
Mine doesnt seem to have the circular cover in the carpeted floor to access a drain and although there is a through hull fitting for water discharge up forward of the back bilge discharge, its plugged a couple of inches inside the hull and their is no bilge pump in the center opening of the gastank where the cover would access. Looks like some had a plug, some had a bilge pump, and some had neither. Since mine was early 2001, must have been left off. I'll have the floor panel out again tomorrow and take another look for the plug but didnt find anything unerneath the hull last time i looked. As people have said, it accumulates more water there then i would prefer so will likely look into wiring a second ballets pump and taking advantage of the already installed through hull fitting.

Thaks to all for your replies!
Ross

lintwurm
06-21-2012, 10:54 AM
On my 2000 X-Star which is a 205V there's one at the back and one in the hull towards the bow of the boat after the fuel tank, accessible by opening the circular cover in the middle of the floor.