PDA

View Full Version : Rudder Issue X9


JBrew
06-19-2012, 09:26 AM
Was cleaning under the boat this weekend and noticed my rudder was loose. I can wiggle it forward and backward as well as a little side-to-side. When I move it around water leaks from in the boat. Is this normal? Any thoughts, ideas, suggestions? Thanks in advancer

ttu
06-19-2012, 09:27 AM
no not normal. try greasing the rudder first and if that doesn't do it you may have to replace either the o-rings or the seal depending on what year your x9 is.

JBrew
06-19-2012, 09:31 AM
no not normal. try greasing the rudder first and if that doesn't do it you may have to replace either the o-rings or the seal depending on what year your x9 is.

Thanks ttu, didn't think it was. I will start from there.

It's an 05 btw

JBrew
06-20-2012, 09:53 AM
Is there a supporting shaft or collar that would cause the wobble? Or is the seal the only culprit ?

Jerseydave
06-20-2012, 06:41 PM
I think your rudder port has bushings in it, perhaps that are a bit worn.
My '05 X-star uses o-rings in the port so maybe new o-rings plus greasing it will buy you some time before you have to replace the rudder port.

Remove the rudder and check it out, it's not hard to remove. Check the rudder shaft for wear as well while it's out.

JBrew
07-01-2012, 01:23 PM
Anyone know where the zerk fitting is? I swear there isnt one!

OHpage21
07-11-2012, 07:21 PM
I just had the same problem on my X9. I pulled the box and sent it to Eric at OJ. He rebuilt and pressed new bushings into the rudder box. If you can pull it and get it to him, I highly recommend it. They received the box on a monday and shipped it back same day. Excellent service.