PDA

View Full Version : X2 2007 bilge setup


weirdElk
06-04-2012, 04:19 PM
Hi guys,

can anyone tell me, where front and aft bilge pumps and the automatic swim switch for the pumps have to be located on a 2007 X2? I almost crawled in every hole of that boat and couldn't find em. I thought the front one has to be under the center cover on the ground between driver seat and glovebox and the rear one has to be near the engine down in the bilge. Both of em don't run in manual mode and I just want to fix/replace them. Maybe the previous owner removed them and didn't replace...? :(

And where is that swimming switch for the auto mode?

Thanks in advance!

BrooksfamX2
06-04-2012, 04:52 PM
On my 2007 X2 the front is in the bilge under the deck plate near the drain plug. The aft one is under the engine on the starboard side and hard to see unless you stick your head down in there.

What is the swimming switch???

weirdElk
06-04-2012, 05:04 PM
Hmm.. I'm pretty sure I had my head down there and didn't see it. I will have a look again, just can't believe the pump is not there.

@swimming switch: I just called it swimming switch, it's the sensor that switches on the bilge pumps automatically, when water fills the bilge. Looks like a little box that just moves up and switches the pumps on. At least that's the way I know how auto mode on bilge pumps works.

ttu
06-04-2012, 05:05 PM
On my 2007 X2 the front is in the bilge under the deck plate near the drain plug. The aft one is under the engine on the starboard side and hard to see unless you stick your head down in there.

What is the swimming switch???

same place on my 07 x2.

weirdElk
06-04-2012, 05:08 PM
swimming switch aka. float switch ;)

GoneBoatN
06-04-2012, 05:12 PM
Bilge pumps tend to have the float switch integrated into the pump now days. You can test by submerging the pump into a small container of water.

weirdElk
06-04-2012, 05:38 PM
So I'm a little oldschool and may stop searching for the float switch. ;)

Thanks guys, I'll keep my eyes open for the pumps.

BrooksfamX2
06-04-2012, 05:58 PM
Bilge pumps tend to have the float switch integrated into the pump now days. You can test by submerging the pump into a small container of water.

Yep, my float switches are integrated into the pump........... you can just turn the pump up-side-down and it should turn on.

weirdElk
06-11-2012, 04:29 AM
I got through all that bilge crap now.
The front bilge pump war near the drain plug too, I just couldn't see it, because the pump was VERY dirty and the top plate was open. So it wasn't working anymore and I replaced it by a new Rule Mate 750 WITH INTEGRATED FLOAT SWITCH. :)
The rear one has to be located on starboard side right under the engine, but there was none! The previous owner removed it for some reason and it took me about an hour to find the right cable down there. Now it's installed and both pumps are running.

THX guys!

greets

BrooksfamX2
06-11-2012, 09:58 AM
Glad you got it figured out...........