PDA

View Full Version : No power to radio on 2008 X2


Masternorth
06-04-2012, 09:47 AM
Hi,

There is no power to my radio. I have changed the fuse that is right at the battery and checked the one below the steering wheel. Where else should I check? The batteries were not correctly connected by the dealer that has winterized my boat and I am worried about more serious damage. Before I go back there, I want to identify the problem if I can. Is there a fuse on the amp?

Thanks

rgardjr1
06-04-2012, 11:35 PM
Hi,

There is no power to my radio. I have changed the fuse that is right at the battery and checked the one below the steering wheel. Where else should I check? The batteries were not correctly connected by the dealer that has winterized my boat and I am worried about more serious damage. Before I go back there, I want to identify the problem if I can. Is there a fuse on the amp?

Thanks

The fuse right at the battery is probably for the amp. There should be a fuse on the power wire near the back of the head unit.

Masternorth
06-05-2012, 01:33 PM
The fuse right at the battery is probably for the amp. There should be a fuse on the power wire near the back of the head unit.

I looked quickly last week-end through the front seat opening and I did not see it but I guess I will have to lie down under it with a good flashlight.

Would you know what type of fuse goes there?

Thanks,

rgardjr1
06-05-2012, 02:01 PM
I looked quickly last week-end through the front seat opening and I did not see it but I guess I will have to lie down under it with a good flashlight.

Would you know what type of fuse goes there?

Thanks,

I'm pretty sure it's a square blade automotive fuse. I think it will be in a black plastic holder. My boat is an hour away so I can't check for size.

Masternorth
06-06-2012, 09:19 AM
Thanks for the info, my boat is also an hour + away so it will wait for the week-end...

cal2vin
06-11-2012, 01:02 AM
This happened to mine stereo as well. It was a bad breaker in that panel under the steering wheel. Since I don't have the seat heat option i just moved the stereo wires from its original breaker to the seat heat one and haven't had a problem since. Although now there is constant power to the stereo. The key does not shut it off so you have to remember to turn it off manually when you are done.

Masternorth
06-11-2012, 10:45 AM
It was finally the fuse on the power source to the radio, underneath the glove compartment. It is a 15 amp fuse and I changed it and everything is back to normal.

Thanks for all the tips.

Robert