PDA

View Full Version : 2012 BIG Firware Update


bjames
05-28-2012, 01:46 PM
Is this someting that the end user can install via USB port? Or can only the dealer update? I see that the BIG has a software update feature and it would be nice if I could do the update myself.

j.mccreight@hotmail.com
05-28-2012, 09:23 PM
Is this someting that the end user can install via USB port? Or can only the dealer update? I see that the BIG has a software update feature and it would be nice if I could do the update myself.

Have the dealer do it at your 10 hr service.

Mastercraftdave
05-28-2012, 10:34 PM
What does the update do? My boat is in for it 20 hr sevice. Would the dealer have this on-hand?

Waterski-Marcoisland
05-28-2012, 11:12 PM
it can be emailed to you, put it on a thumb drive place in usb then turn on ignition...done..
ask your dealer to email u the update

bjames
05-31-2012, 06:07 PM
it can be emailed to you, put it on a thumb drive place in usb then turn on ignition...done..
ask your dealer to email u the update

I asked my dealer and they have not heard of an update, which Im surprised that either they are not up to speed on recent developments/issues with the big, or if MC has not issued a firmware update yet based on the problems people are experiencing.

Anyone know or have access to this update?

ddanenberger
05-31-2012, 10:09 PM
I asked my dealer and they have not heard of an update, which Im surprised that either they are not up to speed on recent developments/issues with the big, or if MC has not issued a firmware update yet based on the problems people are experiencing.

Anyone know or have access to this update?

I am not aware of a BIG update only a GDIG update.

Jonb1822
05-31-2012, 11:44 PM
I asked my dealer and they have not heard of an update, which Im surprised that either they are not up to speed on recent developments/issues with the big, or if MC has not issued a firmware update yet based on the problems people are experiencing.

Anyone know or have access to this update?

My dealer just sent me an update today. I will be updating tomorrow. He said they just released an update, but I have a 2011, not sure if that matters.

GoneBoatN
06-01-2012, 12:08 AM
If you do a version update record the versions before and after. On my 2010 the dealer thought they were doing an update and turned out it was the same version. Later on they did have a version update. :D

AZX45OD
06-01-2012, 12:11 AM
My dealer said that he had "just installed the new update" for my 2012 BIG when I took delivery in April. I am in need of another, however, to get mine working correctly. So, according to my dealer, one came through in March or April, but another is sorely needed and is "on its way."

Jonb1822
06-01-2012, 12:26 AM
If you do a version update record the versions before and after. On my 2010 the dealer thought they were doing an update and turned out it was the same version. Later on they did have a version update. :D

I will do the update tomorrow and report back on the version numbers, so then maybe we will be able to tell if this is a recent update.

Mastercraftdave
06-04-2012, 09:36 AM
While my boat was in the shop last week I got them to install the update that you guys mentioned on this thread and it is still doing the same thing. When I fill the plug and play it works perfectly. However when I drain them it chages the percentage from 100% to 0% which makes the pumps cut off right away.

In order to drain them I had to flip the switch on and off to drain the sacks which was annoying as hell.

Anyone know a solution to this problem?

bjames
06-05-2012, 11:39 AM
While my boat was in the shop last week I got them to install the update that you guys mentioned on this thread and it is still doing the same thing. When I fill the plug and play it works perfectly. However when I drain them it chages the percentage from 100% to 0% which makes the pumps cut off right away.

In order to drain them I had to flip the switch on and off to drain the sacks which was annoying as hell.

Anyone know a solution to this problem?

Nope... this is a problam I and many others are having. Also looks like there isnt a way to change the timers either.:confused:

Mastercraftdave
06-05-2012, 02:29 PM
Nope... this is a problam I and many others are having. Also looks like there isnt a way to change the timers either.:confused:

Well I hope mastercraft figures out something fast. We paid alot of money for these boats and this shouldnt be happening!!

Anyone get in touch with the factory and see what they say?

Mastercraftdave
06-06-2012, 08:59 AM
So I talked to our dealer yesterday after noon and he said that MC does have a file that can be loaded onto a thumb drive that will fix this problem. He is going to try and send me the file today or tomorrow. Ill let ya know how that goes. if you hear anything that will fix it besdies this let me know

ddanenberger
06-06-2012, 09:02 AM
So I talked to our dealer yesterday after noon and he said that MC does have a file that can be loaded onto a thumb drive that will fix this problem. He is going to try and send me the file today or tomorrow. Ill let ya know how that goes. if you hear anything that will fix it besdies this let me know

for ours with zero off they change out the GDIG (center gauge), the update did not work. I have not tested it since they installed the gauge, but the dealer said it is working properly now.

Mastercraftdave
06-06-2012, 02:03 PM
for ours with zero off they change out the GDIG (center gauge), the update did not work. I have not tested it since they installed the gauge, but the dealer said it is working properly now.

Can you go into a little more detail as to what you mean by pulling out the center gauge?

I was told this update taht our dealer is going to get did something with the timers? Not 100% excalty what it does but I will find out soon enough.

Yours might be a good option. What will this do?

ddanenberger
06-06-2012, 02:18 PM
Can you go into a little more detail as to what you mean by pulling out the center gauge?

I was told this update taht our dealer is going to get did something with the timers? Not 100% excalty what it does but I will find out soon enough.

Yours might be a good option. What will this do?

The clam by MC is that the GDIG or center speedo gauge is the first devices on the CAN Bus. It has a controls some of the ballast and speed controls when you do not have the BIG system. The GDIG (which was the software update) is for lack of better terms "fighting" with the BIG computer and causing conflicts. They repalced the gauge with a new generation gauge which allows the BIG to have priority onthe CAN BUS...so I have been told.

Our dealer indicated the timers are gone for '12 they are reling on pump revolutions to determine if the tanks are filled. I will put up with the ballast issue if they can get the speed control working. Docking the boat and Zero Off kicking in is a problem.

Nick911
06-06-2012, 10:20 PM
Speed control is huge but so is ballast! If I can't see what's in my ballast tanks that's a huge problem! Have a service appointment in a few days see if they can sort it out.

Jibber
06-07-2012, 02:45 PM
Iīve just installed the update to the gdig from version 0.16 to version 0.20 because i have issues with the build in Ballast. Itīs a X2 2012. When I drain them it changes the percentage from 100% to 0% (only on starboard side) which makes the pump cut off right away. And the Tank is half Full. To emptying it i have to flip the switch every 3 seconds. Thats so boring!
This is what the update should do:
"CONDITION:
MasterCraft Boat Company has determined that on some
boats equipped with the GDIG functionality, ballast pumps may
shut off before the ballast tanks have completely emptied. This
can create a number of problems, including but not limited to,
freezing of water in the tanks and/or lines, which could result in
damage to the system."
Has anyone Ideas how the ballast pumps exactly works? What communicate with the Gdig that says ballast full or empty? Is it Timer based? I īve paid a lot of money for a brand new Boat and no one can say me how exactly it works. Medallion have no actual manuals for the gdig. That sucks!
Now i have only one Idea which i could test. If I change the electrical connection from the port side Pump to the starboard side Pump and the bug change to, than the Pump is faulty. Is it right?
Has anyone else such a Problem with the Ballast (not with the P&P Ballast and no BIG).
Thanks for every idea

ddanenberger
06-12-2012, 10:21 PM
After changing out the GDIG and reprogramming it for a X-25 thing actually are working. We now have speed control, ballast control, and tabs. It also cleared up the engine light as well and shallow water alarms.

This seem the be the culprit

ddanenberger
06-12-2012, 10:21 PM
After changing out the GDIG and reprogramming it for a X-25 things actually are working. We now have speed control, ballast control, and tabs. It also cleared up the engine light as well and shallow water alarms.

This seem the be the culprit

Nick911
06-12-2012, 11:29 PM
Are your ballast tanks working now, showing the correct percentages?

ddanenberger
06-13-2012, 08:02 AM
yes, although have have only spent about 45 minutes testing last night. everything seem to be accurate ...or relatively acurrate. the tanks went into overflow at 96% and emptied at 0%. I don't have Plug and Play so I can't speak on that.

Mastercraftdave
06-14-2012, 11:44 AM
My tank ballast works fine however, PnP ballast % goes straight to 0% when you hit the drain switch. We got in touch with Mastercraft and they told us they are working on the problem and should have something soon because it is something to do with the software.

Anyone get a fix yet for the PnP that im unaware of?

Stefan
06-14-2012, 05:11 PM
After changing out the GDIG and reprogramming it for a X-25 things actually are working. We now have speed control, ballast control, and tabs. It also cleared up the engine light as well and shallow water alarms.

This seem the be the culprit

Hi,

can you say what's actually been done? I'm wrestling with similar problems, cruise, tabs and in my case GDIG (Impeller) Speedo not working correctly, did you just do the GDIG update or what do you mean by "reprogramming it for a X-25"?

Thanks Stefan

ddanenberger
06-14-2012, 05:29 PM
Hi,

can you say what's actually been done? I'm wrestling with similar problems, cruise, tabs and in my case GDIG (Impeller) Speedo not working correctly, did you just do the GDIG update or what do you mean by "reprogramming it for a X-25"?

Thanks Stefan

They changed out the GDIG to a non "zero off" GDIG. If you scroll through the GDID you will find a configuration screen. Using the select button and the scroll button you can go through the programming.

As I recall the first setting is type of boat...then I believe it ask if you have ballast, then additional bags, then attitude plate and surf tabs.

Ours was set for a x15 (not 25) with no ballast, not surf tabs, and no plate. to fix the programming you just select and scroll between yes and no. at the end it ask if you want to save. Very simple

Stefan
06-14-2012, 07:17 PM
They changed out the GDIG to a non "zero off" GDIG. If you scroll through the GDID you will find a configuration screen. Using the select button and the scroll button you can go through the programming.

As I recall the first setting is type of boat...then I believe it ask if you have ballast, then additional bags, then attitude plate and surf tabs.

Ours was set for a x15 (not 25) with no ballast, not surf tabs, and no plate. to fix the programming you just select and scroll between yes and no. at the end it ask if you want to save. Very simple

I'm not quite sure of the issues you were having but my problem is that I had my dealer add a BIG with ZeroOff(GPS) before I got the boat. From the factory the boat had no BIG and no ZeroOff. As far as I remember the configuraton menu in the GDIG originally installed, everything seems to match the boat's config. But the question is, can the GDIG without the ZeroOff Logo be used with the BIG and ZeroOff. And maybe something else needs to be changed to make it work.
I'm planning on updating the GDIG software this weekend when I get the boat into the water, and in that case should I update with the new GDIG Version with or without ZeroOff...

ddanenberger
06-15-2012, 12:26 AM
ours had the logo, they claimed that was the problem...should not have had the logo...tonight everything went to sh!t again. THe GDIG swap did not work. Zero off remains flaky as erver. come on even when shut off and fluctuates by over 10mph when it is on. dealing looking at it again in the am, but this is crap.

Stefan
06-15-2012, 03:02 AM
I'm assuming the difference between GDIG with or without ZeroOff Logo is two different firmware Versions which are on the Updater, so probably one uses the GPS speed reading while the other one uses the one from the Impeller...

Stefan
06-17-2012, 06:20 PM
So for me the GDIG Firmware update didn't do anything, no matter if it's the one with or without ZeroOff, my cruise, speedo and surftab problems remain... :mad:

ddanenberger
06-17-2012, 09:10 PM
This time they disconnected the paddle wheel . Seems better but lost all quick list settings. Still having issues

AZX45OD
06-17-2012, 11:59 PM
So, did MC test any of this before launching the product? Or are they using us who have paid out the nose for these boats as their test fleet? These boats should be great in a few years once the bugs are worked out. Mine goes back in to the shop tomorrow...

Stefan
06-18-2012, 03:36 AM
So, did MC test any of this before launching the product? Or are they using us who have paid out the nose for these boats as their test fleet? These boats should be great in a few years once the bugs are worked out. Mine goes back in to the shop tomorrow...

I've been thinking about that for a while now... if they'd asked me I'd gone to Tennessee or Florida for a week to test it thoughly for them... :)

Stefan
06-21-2012, 01:35 PM
Switched the GDIG at the dealership today, and in a first brief test suddenly all my problems are gone! My cruise works nearly perfect, my surftabs extend all the way to 100% and stay there, and my speedo works like it should. A BIG THANKS to everyone involved :-) now we'll just have to wait for a BIG update to fix the issues there...
btw. the most recent GDIG Firmware the new boats get seems to be V0.23

sorry it I post this in every concerning thread

Jibber
06-21-2012, 03:03 PM
Switched the GDIG at the dealership today, and in a first brief test suddenly all my problems are gone! My cruise works nearly perfect, my surftabs extend all the way to 100% and stay there, and my speedo works like it should. A BIG THANKS to everyone involved :-) now we'll just have to wait for a BIG update to fix the issues there...
btw. the most recent GDIG Firmware the new boats get seems to be V0.23

sorry it I post this in every concerning thread

Glad to hear that your problems gone! Hopfully the update will be fix mine ballast Problem

Stefan
06-25-2012, 05:57 PM
I found out today that what I posted earlier http://www.youtube.com/watch?v=S9v7JN4HO4A doesn't happen when I switch my BIG to english units, seems to happen only with metric units...

Stefan
07-05-2012, 02:16 AM
After having a working cruise for one weekend everything went back to the aweful way it was before. My cruise only works once and only when activated between 1000 and 2500 rpm and my speedo shows way to much, about 1.5 to 2 times...

btw mastercraft GB now says the GDIG's can't be updated to v0.22, the dealer has to put in a new one :confused::confused::confused:

Jibber
07-07-2012, 06:08 AM
I canīt believe! A manual is online for the 2012 Madallion Gdig System on Mastercraft/knowlegecenter/owners manual!

Jonb1822
08-06-2012, 04:42 PM
Does anyone have an issue with the BIG display is flashing a green line randomly?