PDA

View Full Version : 94' Prostar 205 Belt Squeal/Squeak?


shocker47
05-20-2012, 10:48 PM
Hey guys, I have a 94' Prostar 205 and just got the boat summarized. Last season this started to happen near the end and now it seems worse. Well when I start the engine cold or even warm I will her the belt squeal on idle and even more when i give it gas. I usually just wait about a minute or so for the squeal to stop then give it gas and go. Could this mean I need a new belt? Before I tried to tighten it and it helped a little bit but got back to being squeal. How can I check for the alignment? And what size belt does this take?

east tx skier
05-20-2012, 11:06 PM
When I had this start happening on my 93, a belt change solved the problem.

shocker47
05-20-2012, 11:18 PM
Any certain brand belt I should be using? Also what size/model belt?

east tx skier
05-20-2012, 11:22 PM
I actually took my boat to a local auto parts shop and matched it to a comparable truck engine. They even installed it for me. Ran me about $10.

Or, check skidim.com or a MC dealer. Belt sets are pretty cheap.

sp00ky
05-20-2012, 11:27 PM
Any certain brand belt I should be using? Also what size/model belt?

NAPA belt XL 7420 is what fits my 94 205. Buy 2 for a spare to keep in the boat and check to make sure rusty pulleys aren't eating the belts. Check for excessive belt dust.

93Prostar190
05-20-2012, 11:32 PM
Also check the edges of your pulleys to makes sure nicks, in the pulley are hurting the belt .... Loose belts make noise sometimes as well

ricford
05-20-2012, 11:49 PM
Mine was squealing last year, and I eventually noticed a very small drip from the circulating pump landing on the belt.