PDA

View Full Version : Fuel Pump Electrical Connection - '95 LT-1


bartman
05-15-2012, 07:54 PM
I have a '95 Prostar 190 with the LT-1 in it. The plastic clip that connects the wiring harness to the top of the fuel pump no longer stays connected and the pump will only run if you are applying pressure to the connection (pushing down on the clip).

From what I have been able to tell, this clip is only available as part of a new fuel pump, turning this small plastic clip that should cost $5 to $10 into a $300 part.

Does anyone have any suggestions for alternative ways to connect the power, or where I may be able to buy one of these clips? The picture shows the connection I am talking about.

Thanks!

78873

Table Rocker
05-15-2012, 11:37 PM
I think Stx221 is going to replace his fuel pump. You might PM him with an offer to buy his old clip.

http://mastercraft.com/teamtalk/showthread.php?t=45389

mikeg205
05-15-2012, 11:50 PM
use this tape to secure it if you cant get STX's http://www.amazon.com/Rescue-Silicone-Tape-each/dp/B004MMRMEE

I secured a purge valve connection in my mercedes cuz I droped a two-cent clip. would have cost me about $200 to fix properly... so I used this tape in black plus a couple wire straps...

or maybe a drop or two of silicone sealant...just to hold it in place...

hewlett6621
05-16-2012, 03:59 AM
I have one you can have if you would like to pay the postage.

bartman
05-17-2012, 01:36 PM
Thanks All! I will try to secure the connection for a short term solution. And Hewlett - I sent you a message - if we can work something out, I would love to get the part so that i can do this right!