PDA

View Full Version : 2012 X25 B.I.G. questions


bjames
05-14-2012, 01:29 PM
Have the touch screen BIG and have a couple of questions;

1. When I save rider settings (speed, balast and trim) inside the 'Quick List' screen and save I hit the "Activate" button on the screen. Next I engage the cruis by selecting Cruise On. But I noticed that the trim/ballast settings are not engaging. Am I missing something. Only the speed setting is recalled.

2. How do I change the Perfect Pass settings (KDW, NN ect) The manual does not mention anything about these settings. Currently my PP overshoots by about 4.5 km/hr.

3. HD Camera - How do you start/stop recording from the touch display. selecting the "tag" button does nothing. Does that mean I have to now use the POV unit to start/stop record?

TheWoons
05-14-2012, 01:53 PM
On our 2012 as soon as you hit activate it sets the speed and fills the ballast. The tabs all go to 100% to get on plane and then revert to the saved settings once on plane. Not sure about 2 and 3.

bjames
05-14-2012, 03:54 PM
On our 2012 as soon as you hit activate it sets the speed and fills the ballast. The tabs all go to 100% to get on plane and then revert to the saved settings once on plane. Not sure about 2 and 3.

I will have to try that. Maybe I didnt wait long enough for the ballast to fill, but it seemed like nothing was happening after hitting activate. I will give it another try. ]

As for #2, I am wondering if I have to configure the PP on-line and import it via USB:confused::confused:

Heelgrad
05-14-2012, 05:15 PM
Bjames, just sent you a PM.

CLTMC
05-14-2012, 08:54 PM
I will have to try that. Maybe I didnt wait long enough for the ballast to fill, but it seemed like nothing was happening after hitting activate. I will give it another try. ]

As for #2, I am wondering if I have to configure the PP on-line and import it via USB:confused::confused:

I have been testing many 2012's, so far I have found the best PP Settings to be CS=650 KDW=90 NN=90 this might be a touch on the aggressive side but it will take most of the slop out of the PP pull. Settings might not be perfect for your application but they will be far better than what comes set from the factory. Feel free to play with the settings and report back.

Go to the system- help- screen and click cruise settings to change.
Hope this helps, if you are still not totally satisfied add Zero Off option.
most people surf PP in RPM mode for most accurate pull.

bjames
05-16-2012, 03:24 PM
Help screen.... OK.. I think I went through every other screen but the Help.:o. Its kind of frusterating that accessing some of the set up features is quite hard compared to the 2011 Viper BIG.

Thanks

Nick911
05-26-2012, 09:39 PM
Maiden voyage today with 2012 X25.

Have 6.0 and upgraded prop (15" i think?).

1) Perfect pass seemed to work fine. Overshot by about 2 mph, then within 5 seconds got to my setting and stayed plus/minus .3 mph. This is with factory settings, no ballast, and 5 people in boat. Auto level worked great and reset once I hit speed.

2) Port ballast started shooting water out vent when only 85% full, this normal?

3) Someone elaborate for me on the trim tabs, when I hit left, it lowers the right tab to make the boat roll left?

4) My pitch was showing (err) on the big, and not showing percentages of pitch and roll.

5) Is the depth gauge measuring the distance beneath the boat, or from the water surface?

Haven't tried to activate rider profiles, will try to tomorrow to see if my BIG screen works in that regards. Water temp was 60 degrees and I did get a ride and surf in. I never test drove the boat prior to purchase but was VERY impressed with it today.

Thoughts?

Stefan
06-16-2012, 04:17 PM
2) same on my X-15

3) the labels on the switches mean what the boat will do when you hit the switches, not what the tabs will do, i already relabled my up/down switch and turned it around since I don't find it intuitive either.

4) seems to need calibration