PDA

View Full Version : Help


gts-20
05-07-2012, 12:46 PM
I just picked up my boat from the my MC dealer this weekend.
They worked on my factory JL 6 channel amp that was running the cabin speakers
and sub. The sub was intermitantly cutting out. They traced the problem down to a loose speaker connection at the amp. Anyway, when I dropped it off, the pair
Exile tower speakers I installed a few months ago sounded great. I have them running off of an
Exile Shift 400.4 4 channel amp, bridged to 2 channel. After picking up the
boat, the sound from the tower speakers was muffled and flat, or
"mono" sounding for lack of a better word. It no longer has that
"full" sound, like the sound is only coming from the mid driver...
like there isn't any trebble coming from the tweeter on either
speaker. I checked the amp, and found that the dealer had moved the
RCAs from where I had them (LH frt and RH rear inputs, as per Exile's instructions for bridging), to the front inputs only, and had switched the 2/4 channel input selector from 4ch to 2ch. They left the speaker wires in bridged mode position. I turned off the
system and returned the RCA's and input sellector to where they were
supposed to be, but the sound didn't change. The sound is still flat. The cabins and sub sound fine.

Is it possible that the dealer could have damaged my tower speakers or
amp by moving the RCA's and the input setting? Is there anything else I can check?
Everything sounded great when I dropped the boat off.

I attached a PDF of the way the amp was connected, and a pic of the amp set up.

Thanks in advance for you help.

j.mccreight@hotmail.com
05-09-2012, 09:08 PM
Sorry can't help with your setup but. Did you ever get your tower speakers figured out? Did you call tsr to see what they suggest?

Trojan Fan
05-10-2012, 01:48 AM
Check the crossover(s) on the exile and see if it got switched to low pass only....then report back

gts-20
05-10-2012, 09:36 AM
I checked all the cross over settings. Everything is/has been put back to where it is supposed to be. I contacted Exile and followed their directions on how to test the speakers. The tests confirmed that the tweeters are blown. My dealer is working with me on getting the issue corrected.

swatguy
05-10-2012, 10:54 AM
Wow. Def their fubar........keep us posted. Gooduck