PDA

View Full Version : Fuel cuts off


Spike5
08-16-2005, 11:35 PM
1997 prostar I have a problem with the fuel shutting one of the carb injectors off, this only happens when pulling a adult salomn skier at 40 mph. Then it can be reset by shut the engine off and it starts up and runs fine. I switched the wire from one to the other injector and the problem followed the wire. Have tried a new computor from the dealer new water pump new fuel pumpnew filters every six months. It wont act up for the dealer because it only does when it is under a good load. Just cruising it never does it. Just put in new plug and wires.
Thanks SPIKE5, anything that might help short of buying a new boat

JimN
08-17-2005, 12:03 AM
Have you had the dealer in the boat on the water? This kind of problem can't be fixed without getting it into the same situation, at the dealership. Usually, one injector will shut off when the motor has overheated so the dealer should connect the diagnostic computer and see if this has happened. The ECM stores overheat for 300 key on cycles, so there's a pretty good amount of data. Do you regularly clean out the oil cooler?

From what you have said, the dealer hasn't done much to diagnose the issues. Wiggling the wires is one of the first things in finding a problem. First, they need to do a visual inspection, then verify it, wiggle test, THEN do the other things. This could be as simple as a bad terminal in the injector wires. They should be able to find that. You could also look at the bad injector plug. There are times where the clip breaks off and this will not always act up.

FYI- if it has injectors, it's a throttle body, not a carb. Just being picky.

Workin' 4 Toys
08-17-2005, 09:25 AM
Spike5, I agree with Jim.