PDA

View Full Version : Towing with Audi Q7?


EA2010
04-18-2012, 06:43 PM
If anyone out there is towing with an Audi Q7, please let me know if you had any problem with your trailer lights not working ...

I've tried two different harnesses from Audi - and my trailer lights (2012 X-25) only light up very faint ... with no reverse lights, no signal lights and no flashers.

Very frustrating ... :mad:

ttu
04-18-2012, 06:54 PM
can't help you with the trailer lights but curious how it tows.

i have been thinking about buying one with the tdi engine. also how has reliablity been so far?

i am sure someone will chime in here soon to help you with the issue.

mikeg205
04-18-2012, 07:02 PM
the light issue is a ground issue.... If you have jumper cables you can check the trailer really easily. I had the same problem crop up in my van... had to detach and attach ground wire on my so called professionally installed hitch.

CottagerGreg
04-18-2012, 08:44 PM
Do a search on vwvortex.com

I have an OEM VW harness for my trailer. I will see it on the weekend as i am picking up my boat from winter storage

j.mccreight@hotmail.com
04-18-2012, 09:51 PM
Did the Q7 come from Audi already equipped with the tow package? If not and the dealer or any other shop for that matter installed it, then you need to have Audi hookup their VAG(scan tool) and reprogram your Q7 to accept towing configuration. Also make sure your settings are for the US(which includes Canada) and not EU. bc the EU uses a pulse wave instead of a steady 12v like here in US, it's all controlled internally in the C.U. Also another thing that can cause the coding to mess up is running the battery dead, disconnecting the battery or any other method of losing your 12v for the car computers, you will if not already experienced this when your audio unit locks out and you need to enter the code...

mikeg205
04-18-2012, 11:20 PM
Did the Q7 come from Audi already equipped with the tow package? If not and the dealer or any other shop for that matter installed it, then you need to have Audi hookup their VAG(scan tool) and reprogram your Q7 to accept towing configuration. Also make sure your settings are for the US(which includes Canada) and not EU. bc the EU uses a pulse wave instead of a steady 12v like here in US, it's all controlled internally in the C.U. Also another thing that can cause the coding to mess up is running the battery dead, disconnecting the battery or any other method of losing your 12v for the car computers, you will if not already experienced this when your audio unit locks out and you need to enter the code...

Jim you are a car god!

fskof
04-18-2012, 11:34 PM
Does your trailer have LED lights? if so you will need to get an adapter for the led's to work. I had to buy one for my 2004 VW Touareg.


http://www.etrailer.com/Wiring/Tow-Ready/TR20141.html

AZX9
04-19-2012, 01:59 AM
The most interesting man in the world is correct. You may need to have your system flashed for American trailers. I have towed both a standard lighted trailer and an all LED trailer without any changes or problems with my 2011 TDI Touareg. As far as towing with the TDI, it is an amazing vehicle for towing. The Q7 has the same diesel as my Touareg and is a little longer (better) and a little heavier (not so good) and the tow rating is a little lower at about 6600 but would still handle just about any MC besides a 300 or X80.

chippy1971
04-19-2012, 05:59 AM
Hi I have an x15 and I have a Q7 3.0 Turbo Diesel and it does it easy.

I reckon it is a great car for towing and it really is not a problem.

Happy to help if you have more questions.

EA2010
04-19-2012, 12:18 PM
Did the Q7 come from Audi already equipped with the tow package? .... Also make sure your settings are for the US(which includes Canada) and not EU. bc the EU uses a pulse wave instead of a steady 12v like here in US, it's all controlled internally in the C.U.

This makes total sense. When I connect the trailer to the factory lighting harness on the Q7, the main trailer lights light up really dim ... and when I took a photo I noticed a pulsing signal thru the camera lense.

I will approach the Audi dealership on this ...

THANKS!

EA2010
04-19-2012, 12:20 PM
Does your trailer have LED lights? if so you will need to get an adapter for the led's to work. I had to buy one for my 2004 VW Touareg.


http://www.etrailer.com/Wiring/Tow-Ready/TR20141.html

Just talked to the Audi dealer and they suggested this part as well. It's definitely a cheaper fix - so I will see if I can source one locally. The alternative is to ask Audi to reprogram to US-spec (opposed to Euro spec) for lighting.

I will keep you all posted. Very much APPRECIATE your feedback! Here's my boat - ready to go ...

east tx skier
04-19-2012, 12:21 PM
Do a search on vwvortex.com

I have an OEM VW harness for my trailer. I will see it on the weekend as i am picking up my boat from winter storage

That place is a very good forum. Learned a lot about my CC over there.

east tx skier
04-19-2012, 12:22 PM
Did the Q7 come from Audi already equipped with the tow package? If not and the dealer or any other shop for that matter installed it, then you need to have Audi hookup their VAG(scan tool) and reprogram your Q7 to accept towing configuration. Also make sure your settings are for the US(which includes Canada) and not EU. bc the EU uses a pulse wave instead of a steady 12v like here in US, it's all controlled internally in the C.U. Also another thing that can cause the coding to mess up is running the battery dead, disconnecting the battery or any other method of losing your 12v for the car computers, you will if not already experienced this when your audio unit locks out and you need to enter the code...

If you don't have one, there used to be a VAG-COM (VCDS) search map on one of the VW forums. Basically helps you find someone near you with one that might be willing to tweak your settings for a six pack. My VW charges $100 just to plug theirs in. They retail for about $250.

east tx skier
04-19-2012, 12:29 PM
Link to VAG-COM Locator Map (http://www.batchgeo.com/map/e0bc1e34678c6588fe1b2a6a5944ad32)

EA2010
04-19-2012, 12:33 PM
If you don't have one, there used to be a VAG-COM (VCDS) search map on one of the VW forums. Basically helps you find someone near you with one that might be willing to tweak your settings for a six pack. My VW charges $100 just to plug theirs in. They retail for about $250.

I sent the Calgary guy an email. Thanks for the heads-up!

BrianT
04-19-2012, 12:58 PM
Just talked to the Audi dealer and they suggested this part as well. It's definitely a cheaper fix - so I will see if I can source one locally. The alternative is to ask Audi to reprogram to US-spec (opposed to Euro spec) for lighting.

I will keep you all posted. Very much APPRECIATE your feedback! Here's my boat - ready to go ...

I saw your boat sitting outside MMS, very nice!

EA2010
04-19-2012, 12:59 PM
Cheers, Brian!

BrianT
04-19-2012, 01:06 PM
21 degrees C for the weekend.... almost ready to go! I just need Chestermere to fill up so I can take mine out for the 2012 maiden voyage.

EA2010
04-19-2012, 01:14 PM
The MMS guys tell me they are water testing my boat on Chestermere this weekend!

BrianT
04-19-2012, 02:26 PM
The MMS guys tell me they are water testing my boat on Chestermere this weekend!

They better get filling it then, I drove past it yesterday and it's way low. They wont start filling it until mid May. Unless something changed recently.

BrianT
04-19-2012, 02:45 PM
Just checked the Town of Chestermere website. They started filling the lake on the 16th and will be ready to go no later than the 1st of May. Awesome news! Hopefully the water is up enough for Scott to drop yours in for the test this weekend.

EA2010
04-19-2012, 05:08 PM
Awesome! If everything goes well - and I can actually (legally) start towing my own boat - I might pop out for a cruise if you're out there soon. Keep me posted!

BrianT
04-19-2012, 05:31 PM
Awesome! If everything goes well - and I can actually (legally) start towing my own boat - I might pop out for a cruise if you're out there soon. Keep me posted!

You bet!!!!

fskof
04-20-2012, 12:36 AM
There are many threads about this at the Q7 section of www.audiworld.com

http://forums.audiworld.com/forumdisplay.php?f=112

bonza
05-06-2012, 07:21 AM
better than any Land Cruiser that I drove and fuel economy is crazy with 3.0 tdi i got 15l/100 kms
best get 4.2 tdi - you will still race a few people off the trafic lights

AZX9
05-06-2012, 07:49 PM
No 4.2 TDI stateside.