View Full Version : Bimini Installation

04-17-2012, 12:56 PM
I just bought a 2006 X30. The Bimini was not attached and now I need to install it.

Does anyone know where to find installation instructions, it is not in the mastercraft manual that came with the boat?


04-17-2012, 01:49 PM
If no one comes up with instructions I'll look through my photos and see if I can find something for you. I'll also take some measurements of the mounting points the next time I have it out.

Is this a factory bimini?

04-17-2012, 03:48 PM

Yes it is factory

Pictures would help immensely

04-18-2012, 10:01 PM
I purchased an OEM MC bimini (stainless steel) last year and installed on my X7.
I had no instructions.
it took a while to figure it out.
here is my advice.
set the bimini in place on your boat, pull it to full open.
rig up a bunch of short ropes to "hang" the bimini where you think it should go.
then view the simulated bimini in place from the side view, front view, rear view etc.
take photos from each view and compare to photos you find online.
tweak as necessary.
next simulate the collapsing or folding up of the bimini. check for clearance issues.
I think the factory mounts the bimini feet with rivets? or aluminum inserts in the tower?
I just bought some stainless steel machine screws, then drilled and tapped into tower. Place a cardboard box to catch all drill shavings, to keep them out of carpet.
Mount and enjoy.
Hope this helps.

04-21-2012, 08:49 PM

Did anyone have any pics by chance?

I am hoping they just snap in somewhere on the tower?


05-05-2012, 06:46 PM
All fixed up. Had to buy the end pieces.

Keep on Tryin'
06-20-2016, 03:46 PM
Reviving an old thread here.
If anyone could give me the measurements for where to place the mounting hardware on the tower I would appreciate it.
I have a 2006 X30 and bought an OEM bimini, and mounting hardware. They did not come with any directions.
From pictures I've found online, it appears that the hardware mounts on the inside of the tower legs, not on top of them. I'm sure I can figure it out with trial and error, but would appreciate some help to get me a good starting point.

06-20-2016, 04:37 PM
Well, I guess I need to help close the loop here! I must have forgotten about this thread. Glad the OP got his installed.

Since I'm at the lake and on the boat, here you go.

06-20-2016, 04:40 PM
My phone will only let me attach 1 pic in each post.

06-20-2016, 04:43 PM

06-20-2016, 04:44 PM

06-20-2016, 04:47 PM
Last one.

Keep on Tryin'
06-20-2016, 04:48 PM
That definitely helps!