PDA

View Full Version : Damaged OJ 475 (14.25x14.5) prop


Jason99T/A
04-06-2012, 07:03 PM
Took the boat out today and my friend driving got a little too close to the shore. He hit an under water stump going about 5 mph. Motor killed, started right back up. However, the boat had a very bad vibration over 5-6 MPH. I had to limp back to the launch. Pulled boat out and it wasn't a surprised to see two blades bent. I will attach pictures shortly. Two questions-

Is there a chance the prop shaft could be bent?

Any idea cost to repair through OJ? I sent Eric a PM.

Thanks,
Jason

Jeff d
04-06-2012, 07:16 PM
Shaft or strut could be bent. I'd get the prop fixed and see if any vibrations remain before you worry about that though. Repair should be about $150 for the prop. There's also a prop repair shop in Abbeville that my two nautique acquaintances swear by:
Toups Propeller Service
1413 South State Street, Abbeville, LA 70510
(337) 893-5785

They usually drop their prop off and then have him UPS it back to them which comes next day with ground shipping. I've only needed a repair once after backing into a stump in the Tchefuncte and I shipped it to OJ. I think it took like 10-12 days to get it back since they were busy at the time. Next time I will probably give the Toups dude a shot. They say they usually get the prop back 2-3 days after they drop it off.

Jason99T/A
04-06-2012, 07:32 PM
Thanks. This was on the Tchefuncte River as well. I plan to put the factory prop back on in the morning and give it a run to see if vibration still present. Thanks for the info on Toups. Since I'm not in a huge rush, I will send to OJ.

Jeff d
04-06-2012, 07:47 PM
FWIW I can't remember the name of the prop shop in Covington but I've heard from 3 sources that he can't balance inboard props correctly. My dad uses him at least once every couple of seasons for his SS outboard prop and has had good experiences though.

CantRepeat
04-06-2012, 08:02 PM
If it's an OJ prop I'd send it back to Eric. I'm sure he'd get it fix and back to you within the week.

Jason99T/A
04-07-2012, 02:10 PM
Took the boat out today with factory prop. Boat ran fine. Appears prop shaft is OK. Will be waiting to hear back from Eric @ OJ Props on Monday. Thanks for the input guys.

Tri4X2
04-08-2012, 10:08 AM
Send it to Eric. I got mine back in less than 3 days