PDA

View Full Version : Fuel Pump


psychobilly
04-01-2012, 08:38 PM
Well we went out today for my sons first trip on the boat. Everything was going great. The carb rebuild worked like a dream. She fired up and ran great. We went up to the north end and swam with my young'n fer a couple of hours and then we cranked up to go find gts-20 and his OL. We go to them and anchored up for another couple of hours. We decided our year old boy had enough sun for one day and headed out. I didn't get 500 yards from gts-20 and she died... Opened hood and tried starting her and nothing. Then I noticed that I couldn't hear the fuel pump after letting off the key.... I reckon it's shot now. Crazy thang.... I'm Gunna go ahead and order one but I want to check that wire'n to it. Some how or another I think it's hooked into the solenoid but I ain't sure. If I get back out to the lake later this week and it's working fine, I'm Gunna really be scratching my head. The ole girl is 22 years old. I'm hope'n the wire'n aint bad.

Thanks again to my boy michael for tow'n us back to the ramp. And thank God for those slick ultimate bunk boards!!!!! Cranked her right on the trailer and I know I had hell with the ole carpeted crap before.

((( waiting on Jim N to chime in with electrical tech help here))

02ProstarSammyD
04-01-2012, 08:54 PM
before you trash it put a meter on the connection to make sure you are getting power. Nothing worse than throwing money at a problem

psychobilly
04-01-2012, 09:22 PM
Yeah I'm going to check for power but I'm Gunna go ahead and bite the bullet on new pump. It was working up until today. Not sure why I would loose power all of a sudden.

The reason I'm Gunna go ahead and order a fuel pump is I can't find it around here so if I wait til mid week to order it I'm screwed as it won't be here for the weekend....

psychobilly
04-02-2012, 02:00 PM
Well I didn't order the fuel pump and glad I didn't... I went out and pulled the fuel pump, hooked it straight to the battery and vwolla, it runs. So that mean I ain't getting power to it. Had to head back home and take the boy to the doctor as he's runnin a temp after his trip to the lake....

j.mccreight@hotmail.com
04-02-2012, 11:00 PM
e-mail sent...

bturner2
04-03-2012, 06:52 AM
I had a 89 TriStar that acted very similar. Ended up being the ignition switch. Sounds electrical to me.

gts-20
04-06-2012, 10:10 AM
psychobilly,

How's your son feelin'? Better I hope. Any luck fixing your fuel pump/wiring issues?

02ProstarSammyD
04-06-2012, 10:15 AM
Well I didn't order the fuel pump and glad I didn't... I went out and pulled the fuel pump, hooked it straight to the battery and vwolla, it runs. So that mean I ain't getting power to it. Had to head back home and take the boy to the doctor as he's runnin a temp after his trip to the lake....
Well thats good news hopefully! Hate to ask but lanyard?