PDA

View Full Version : Calibrating Lake Temp Sensor?


seth25
03-30-2012, 11:12 PM
04 X30 water temp is reading about 10 degrees low. Is there a way to calibrate?

Thanks

93Prostar190
03-30-2012, 11:42 PM
I want know too! Except mine says the water is much warmer .....2008 in my case.

seth25
03-30-2012, 11:51 PM
http://www.mastercraft.com/teamtalk/archive/index.php/t-36992.html

Just found this. Looks like no real way to calibrate. Mine is readin 40 degrees.

WTRSK1R
04-01-2012, 09:59 PM
If I remember correctly, 40 degrees is what it reads when the pickup is disconnected.

WTRSK1R
04-01-2012, 10:02 PM
One other thing, mine was about 5 degrees low and afetr tightening all the ground connections on a ground bus under the dash near the steering wheel it is now within about 1 degree of a meat thermometer on the lake surface.

willyt
04-02-2012, 08:34 AM
I want know too! Except mine says the water is much warmer .....2008 in my case.

Then you really have no excuse for why I didn't see you at oshay yesterday

93Prostar190
04-02-2012, 11:03 AM
Then you really have no excuse for why I didn't see you at oshay yesterday

Did you just hi-jack a thread to pick on me not being at the lake? ..... dude I will be driving you one day and there will be some speed control issues with the cruise control .... ;)

Peace.

musicmd
06-18-2013, 07:50 PM
I'm curious about my lake temp sensor. I have a 2004 X-10 and the lake temp is stuck on 95 degrees. Is this a result of a short somewhere or a faulty sensor?

musicmd
07-01-2013, 08:59 AM
Strangely enough, yesterday the water temp was 74-75 degrees, which fits the local measurements. Whatever was causing the earlier problem is now gone (at least for now.)