PDA

View Full Version : TriStar Loading Problems


363COUPE
03-21-2012, 02:37 PM
This is my 3rd TriStar in the past year and every one of them is a PITA to load on the trailer. The bow hits right BELOW the bow roller when trying to load it. It doesn't matter how far the trailer is in the water, it still does it. Has anyone else had this problem and know of a way to correct it?

CantRepeat
03-21-2012, 02:59 PM
I think you are backing the trailer in too deep.

Double D
03-21-2012, 03:03 PM
This is my 3rd TriStar in the past year and every one of them is a PITA to load on the trailer. The bow hits right BELOW the bow roller when trying to load it. It doesn't matter how far the trailer is in the water, it still does it. Has anyone else had this problem and know of a way to correct it?

How steep is your ramp?

pkskier
03-21-2012, 03:05 PM
I've been putting a TriStar on a trailer for 25 years and have never had a problem. I agree it sounds like you are backing in too far.

363COUPE
03-21-2012, 03:09 PM
The ramp isn't that steep. I've loaded 100's of boat and never had a problem but these 3 TriStars are terrible. I had a buddy with one last year and his was the same way. The ONLY way to get it to load correctly is by having the trailer to far out of the water and you have to have someone on the winch while someone is on the throttle to get it up because it's so far out of the water the prop wont push it by itself.

Double D
03-21-2012, 03:22 PM
Got a picture of how high the bow roller is?? Do you have a V-Pad to bring the nose up?

363COUPE
03-21-2012, 03:31 PM
These are the only pics I have right now. I took the boat buddy off and put a roller on it.
http://i580.photobucket.com/albums/ss248/363coupe/1991%20masterCraft%20TriStar/914535d4.jpg
http://i580.photobucket.com/albums/ss248/363coupe/1991%20masterCraft%20TriStar/bf7f7f90.jpg
http://i580.photobucket.com/albums/ss248/363coupe/1991%20masterCraft%20TriStar/df5856ec.jpg
http://i580.photobucket.com/albums/ss248/363coupe/1991%20masterCraft%20TriStar/930663f8.jpg