PDA

View Full Version : '07 X2 Amp Wiring


wakeX2wake
03-21-2012, 10:00 AM
Background: i have an 07 X2 which came with a jl audio m6450 (6channel) amp pushing the 4 towers and 4 in the boat + sub... dewinterized by the dealership last yr and the amp fried... so after some kind words i took the amp apart and got the resident electrical engineer phD in the family to check into it... he replaced some parts and it worked for about 2 mins and started smoking... long story short he needs a schematic to completely fix it and i told him to drop it i'll buy another one cause his time is pretty valuable... before i took the amp out i took several pics w/ my iphone of what wiring went where and at some point between then and now i killed my iphone w/ none of the pics getting backed up #lessonlearned

Question: does anyone out there have a pic of the factory amp wiring for an 07 x2 w/ the jl audio m6450?... aka what colors go where... i can probably figure it out but i would feel a little better not making another $400 mistake

bturner2
03-21-2012, 11:53 AM
I've got these three which really are not that great but you might be able to get most of what you need between the three of them. I am however running a second amp for the tower speakers.....

bturner2
03-21-2012, 11:55 AM
I'm hoping to get out to work on the boat this weekend and can take more pictures if someone else can't get you better pictures......

wakeX2wake
03-21-2012, 01:37 PM
thanks i really appreciate the look... that should help me get going

bluestreak
03-21-2012, 05:46 PM
You should be able to find the schematic for the amplifier online. Then just test what speaker is what with a battery (positive to positive, negative to negative) Just tap it, don't hold it down. Then you'll know, port, starboard, bow, stern, etc. Connect them accordingly.

wakeX2wake
03-21-2012, 07:22 PM
We looked... apparently a full engineering schematic for a JL Audio amplifier is considered "proprietary information"... o well

I was trying to nail down which speakers ran off which channels and a couple speakers had to be ran off a single channel just... can't... remember... 8.1 speakers and 6 channels dosen't leave it exactly straight forward... but for sure a 9V battery is the way to go when pinning down which speaker belongs to which wire... just don't want to cause an electrical traffic jam and burn that dude up too

hbomb
03-22-2012, 05:34 AM
cabin speakers x4 and 4 x tower cans
M6450 amp on a 2007 X2
hope this helps
colour to + positive
black trace to - negative
cabin is ch 1 & 2
channel 1
white/white black trace
green/green black trace
channel 2
grey/grey black trace
purple/purple black trace
tower - a separate loom with green and purple wire - refer to picture is ch 3&4
channel 3
green/green black trace
channel 4
purple/purple black trace
channel 5 & 6
sub bridged

wakeX2wake
03-22-2012, 10:37 AM
cabin speakers x4 and 4 x tower cans
M6450 amp on a 2007 X2
hope this helps
colour to + positive
black trace to - negative
cabin is ch 1 & 2
channel 1
white/white black trace
green/green black trace
channel 2
grey/grey black trace
purple/purple black trace
tower - a separate loom with green and purple wire - refer to picture is ch 3&4
channel 3
green/green black trace
channel 4
purple/purple black trace
channel 5 & 6
sub bridged

NAILED IT!!! that's perfect... I really appreciate the help

wakeX2wake
03-25-2012, 12:20 AM
amp installed with new battery and the noise is back... thanks for the help

bluestreak
03-25-2012, 02:01 AM
Did somebody run cheap RCA's next to a power wire?

hbomb
03-25-2012, 05:18 AM
well done brother - glad to help