PDA

View Full Version : 2001 X-Star Died andwont Restart


chaneyjl
03-18-2012, 11:37 PM
Was out this weekend and the boat was running perfect. I was behind the boat wakeboarding when i noticed it was starting to cut out. Cleared up after 3-4 times of sputtering. Next Pull after about 30 seconds boat just died and wouldnt restart. Temp seemed good at the time and no other indicators. Boat wants to start, but sounds like it does when you try to start it without the Kill switch attached? Any Suggestions as to what might be the issue?

Thanks

TOO-TALL
03-18-2012, 11:45 PM
So motor turns over,but won't fire?

Maybe fuel pump??

I would rent a fuel pressure gauge from auto zone and start there.

tr6coug
03-19-2012, 01:21 AM
Yeah, sounds like a bad fuel pump.

nmcjr
03-19-2012, 04:26 PM
99% chance its the fuel pump. Buy a fuel pressure gauge to confirm and then visit the fuel pump 101 thread and the aftermarket fuel pump thread. I wouldn't waste money on the replacement MC fuel pump since its the same POS the boat came with.

Jeff d
03-19-2012, 05:10 PM
I will +4 the fact that your symptoms seem to indicate a fuel pump issue and to check pressure before spending money on parts. As a preliminary check you could open the compartment in the rear middle and turn your key to the "On" position (Don't start it) and listen for the pump to prime. You should hear about a 5-10 second whine sound as it primes.

If you don't hear that then check your fuses/breakers if applicable but at that point it's even more likely have a bad pump. If it was a fuse or breaker I would have expected an instant loss of power and no restart. On a fuel injected engine I would NOT expect a sputtering failure over the course of several minutes like you described if it was fuse/breaker related.