PDA

View Full Version : Guages on, guages off


USSDefiant
08-28-2004, 10:39 PM
oil pressure, tach, temp guage will work most of the time but are prone to suddenly cut out. killing, starting will sometimes reset them but not always. comments? boat is 2001 x star vortec 350

also been having throttle problems..... :mad:
gun it pull up skier, PP starts to engage, loss of rpm, boat slows to a fast idle. after stopping and restarting the throttle has no response,
for example you have to floor it to move at all. checked engine and found loose string attached to PP and turned the little knob until the string was tight again. it got us home but I was not sure if the PP has broke or what. wasnt even sure if I should be fiddling with the knob on the PP. comments?? :huh:

John B
08-28-2004, 11:14 PM
When PerfectPass is not working right the first thing to check is the knob on the servo.Ever time I have my engine compartment open I make sure it is tight.I have found it loose when you move the throttle when the motor is not running. The throttle cable pulls it out and the computer is not on to reset it.

JimN
08-28-2004, 11:54 PM
The early boats with the Medallion gauges had some grounding issues on the MDC box. This box controls all of the gauges and if the grounding is bad, they flake out on you. The box has a 5 year warranty on it, so you can have your nearest dealer fix or replace it for you. Usually, if you have one gauge go out, it's a gauge problem. If they all go out, it's the black box.

USSDefiant
08-29-2004, 04:02 AM
Jimn can i change the mdc box myself or is a special tool required? i would like to avoid unnecessary downtime at the dealer if possible :)

john b thanx i was worried about fiddling with it glad to know i made the right call :toast:

Tom023
08-29-2004, 09:38 AM
I've been fighting gauge problems for three years and found it to be a combination of a bad MDC and individual gauge problems. Replacing the MDC with a series "G" box made big reliability improvements, but I still had some problems. I've replaced the oil and fuel gauges one at a time, and with the new Rev B gauges in, I've yet to have a problem with those. While I still had a drop out on the volt gauge, my dealer is going to give me a temp, tach and volt gauge to replace all the remaining ones to hopefully solve the problem once and for all.

JimN
08-29-2004, 09:52 AM
Talk to your dealer and see if they can schedule your appointment for a time when you can maybe have them diagnose the problem while you wait. Diagnosis shouldn't take too long, unless the problem doesn't occur at that time. They need to see it inoperable because it's still at least partially under warranty unless you're not the original owner. See what they can do for you about not having the boat for too long or you can wait till the end of the season to take it in when you won't be using it.

USSDefiant
08-29-2004, 10:42 AM
took boat out again this morning guages were working, but the pp still isnt working. it tries to engage but all speed drops off. checked engine and tightened knob again but with no success. runs fine with pp off. i dont know if the servo is working or what :confused:

JimN
08-29-2004, 12:27 PM
If the PP was installed after you go the boat, the ground path may not be as good as needed. If it shares the ground with the MDC box, it partially explains the problem. Shared grounds cause all kinds of weird things to happen from one device needing more current and making up the difference netween what exists and what it needs through the easiest path available.

east tx skier
08-31-2004, 10:23 AM
John, I had the same knob problems when I first got PP. The dealer had mounted the PP servo a little too vertically and the knob was falling off, resulting in a dead stick.