PDA

View Full Version : front ballast bag input broken


cwarndahl
02-22-2012, 12:43 PM
Before i just dig into this repair i though i would post it and see what peoples experience with it is. my ballast input hose broke. I'm having a hard time from my local MC dealer finding the part. also any one know how hard it is. here is a pic 2001 X-10 thanks in advance.

JRW160
02-22-2012, 02:51 PM
It looks like the fitting detached from the bag. The same thing happened to my ski locker sac. Several people told me it couldn't be repaired. I used PL construction adhesive and it held up find all of last summer. I think you can get it at home depot or lowes.
http://www.amazon.com/Henkel-828471-Polyurethane-Construction-10-2-Ounce/dp/B0002YVJG8

Jeff d
02-22-2012, 03:16 PM
I've heard of using a plastic thru hull fitting like this:
http://www.wakemakers.com/black-thru-hull.html

and PVC cement like from the plumbing section at the hardware store. Cram the thru hull through the hole, coat everything with the cement, then tighten the nut down. Then connect your hose to the barbed end.

That construction adhesive may provide enough of a mechanical bond to work ok but I doubt it provides a chemical bond like the PVC cement does when used with PVC components. I've had good success patching a sac with a scrap of PVC material and the PVC cement. How well it would bond to that plastic thru hull would depend on the chemical composition of the plastic.

cwarndahl
02-26-2012, 02:02 PM
thanks for the ideas. I'm gonna look at this week maybe pull the bag. well see what happens