PDA

View Full Version : x9 2004 randomly stops


Th3Grub
10-12-2011, 10:44 PM
Hi,

I have been enjoying my 09 x4 I just bought about 2 months ago.
But had some problems with it the last weekend I used it.

Driving the boat normally, pulling kids on a tube, the boat just died... Engine stopped all of a sudden. Gas tank was at 1/4, so i thought, ok, maybe i'm turning too much and the engine stopped because it missed gas for a sec. I restarted it no problems and went home for the night....

Next day, filled it up and did about 15 minutes of tubing again when it died again ! :(
But that time, never wanted to start again.... Starter was working fine but engine would not start... Toed it the shore and took it out of the water for winter storage. It was that day anyway :(

I told the mechanics, he did not check it the same day but he called me a couple days later telling me the boat started fine and everything seems fine !!

I checked the safety switch when it did not want to start.. it was well in place...

Any ideas ??? I would like to have the mechanic check stuff before I put it back on the water next summer...

Thanks for you help :)

Huskie05
10-12-2011, 10:49 PM
If I had to guess I would say fuel pump, sounds like it could be going bad.....

mikeg205
10-12-2011, 11:01 PM
could be a clogged fuel filter...no codes from the computer? "seems fine" will suck in the middle of the lake or when drifting down the river. Lot of threads here with 2000 X's having fuel pump issues how many hours on the good ship....

Th3Grub
10-12-2011, 11:12 PM
137hrs on the boat... got it at 116
I have to talk to the mechanic again and see if there were any codes from the computer.

I thought about the fuel pump and they even told me about it when I described the problem, but they later said it wasn't that.

I agree, "seems fine", will definitly suck big time when the boats stops again next summer !! :(

197 TT
10-12-2011, 11:14 PM
this happened to me this summer, it was the fuel pump relay. got worse and worse. less than $20 at NAPA. have an extra one in the boat now.

Th3Grub
10-12-2011, 11:17 PM
this happened to me this summer, it was the fuel pump relay. got worse and worse. less than $20 at NAPA. have an extra one in the boat now.

Oh.. nice to know.. I am not a mechanic at all. I have the 8.1Ltr engine. Where could that fabulous relay be ?

Thanks.

mikeg205
10-12-2011, 11:18 PM
ahhh go to love team talk and NAPA....