PDA

View Full Version : 2012 zero-off and ballast controls


bcd
09-29-2011, 12:42 PM
Has anyone had any experience with the new non-BIG display zero-off and ballast controls? I can't get the boat to stop automatically emptying my ballast when I restart the engine. My owner's manual doesn't even mention the controls. From what my dealer and I found messing with it, you have to hit the cruise on/off switch, then cycle through to the wake full setting, and hit cruise on. This fills the ballast and sets cruise to 21 mph. My problem is once you shut the engine off and restart it, the boat defaults to the auto level function and starts emptying all of the ballast automatically. You have to reset it to wake full mode and then reset your speed if you want something different than 21 mph. There is a setup mode, but I looked through it and couldn't find anything to program default settings. It was mainly for just setting up your boat model and options. My dealer was going to put a call in, but I was wondering if anyone else has run into this.

jwardenjr
09-29-2011, 01:57 PM
Has anyone had any experience with the new non-BIG display zero-off and ballast controls? I can't get the boat to stop automatically emptying my ballast when I restart the engine. My owner's manual doesn't even mention the controls. From what my dealer and I found messing with it, you have to hit the cruise on/off switch, then cycle through to the wake full setting, and hit cruise on. This fills the ballast and sets cruise to 21 mph. My problem is once you shut the engine off and restart it, the boat defaults to the auto level function and starts emptying all of the ballast automatically. You have to reset it to wake full mode and then reset your speed if you want something different than 21 mph. There is a setup mode, but I looked through it and couldn't find anything to program default settings. It was mainly for just setting up your boat model and options. My dealer was going to put a call in, but I was wondering if anyone else has run into this.



Yes ... I am having the same issues and since there is no real manual available itís very frustrating. I find it pretty ridiculous that they have no manual available. The only information they give you is how to go from screen to screen and no information on how the system works. Please let me know what you find ....

REDX2
09-29-2011, 08:50 PM
A buddy and I took a 2012 X25 out on a demo and we had the same problem, needs to be a way to customize your own setting and the only way to use the rear plate is to have the PP on.

jwardenjr
09-29-2011, 09:16 PM
A buddy and I took a 2012 X25 out on a demo and we had the same problem, needs to be a way to customize your own setting and the only way to use the rear plate is to have the PP on.

no you can use the rear plate without PP on ... But what needs to happen is MC needs to give us the manual explaining how it works and how to program it. I have asked my dealer to call the rep and let me know what is going on ? they stuck like 3 pages of information in last years manual that basically show you each page in the new system but no information is given on how it works or how to program. The dealers dont know ... my dealer did not even know about the new auto level and when we went out on a water test was as confused as me.

If you hit the surf tabs by accident I cant figure out how to zero them out with out turning off the boat ?

ddanenberger
09-30-2011, 09:47 AM
On our '11 you have to take the center plate all the way up. This will bring up the surf tabs.

bcd
10-03-2011, 11:47 PM
Got a response back today. The answer I got is when you turn the key off, you also kill power to the ECU and it resets the settings. Instead of turning the key, push the engine start/stop button to shut the engine off, and leave the key in the on position. I originally tried to use the stop button, and it didn't kill the engine. The trick is you have to hold it in until the engine shuts off.

bcd
01-15-2012, 12:26 PM
Bump

Anyone found the solution to filling the aftermarket bags with the stock pump? There's a recall to recalibrate the pumps to get them to empty the tanks all the way. My dealer wants to wait until then to see if he can recalibrate them to fill longer. I'm not sure if this is the best solution or if it will work at all.

Wondering if anyone else has figured this out yet.

swatguy
01-24-2012, 02:56 PM
And so the ballast saga continues. Geeeeezus. How can they not get this right....put in a switch. Fill til u shut it off, empty til you shut it off. Holy crap genius I tell you. Sorry for your issues guys, just been going on since 05ish

MIskier
01-24-2012, 03:02 PM
And so the ballast saga continues. Geeeeezus. How can they not get this right....put in a switch. Fill til u shut it off, empty til you shut it off. Holy crap genius I tell you. Sorry for your issues guys, just been going on since 05ish


Because marketing departments not engineering departments run the companies in this industry...

ChrisAllatoona
04-02-2012, 02:16 PM
Anyone have issues with X25 with the Big screen only showing ballast tanks partly filled and total weight is not full but water from ballast tanks pours out side vents like they are full. I also have latest software update. Thanks...