View Full Version : Steering Column Rattle

09-22-2011, 02:31 PM
I still cant figure out what is causeing the rattle in my steering column.
If I accelerate under load I hear a rattleing sound at the helm.

Everything is tight at the rudder.

My steering wheel does have some up and down movement. But I would assume it is the tilt steering bushing worn out.

Has anyone fixed this problem on there boat.

Do I need a new helm, and tilt steering part?

I looked for nuts to tighten. and found one allen screw. but it was tight.

09-22-2011, 02:42 PM
Mine does the same thing, '04 197. What boat do you have?

09-22-2011, 02:51 PM
1999 X-star

10-06-2011, 02:16 PM

10-06-2011, 02:43 PM
Mine will rattle a bit if I am power loading in shallow water. Only other time is when I bent my prop pretty good. I hit a good sized log while surfing, bent all 4 blades, visually it looked fine to me, prop guy said all 4 blades were major, he could tell just by looking at it, $25/blade later and the prop performs better than new from OJ. After I hit the log, anything over idle speed was very noticeable at the steering wheel (vibration), hence I would have your prop put on the block!

07-09-2015, 02:26 PM
Rebooting this thread, My 98 maristar does this. I get a slight rattle under load at takeoff but afterward everything is good no weird noise or rattle at speed... anyone know what causes this?


08-14-2015, 09:13 PM

Sent from my SCH-I545 using Tapatalk

08-14-2015, 09:23 PM
Does the helm have a slight rock on it (forward/backward not side to side) but steering feels ok ?

I had worn bushes in my tilt helm, the replacement helm now has bearings and cured the problem on my 99. I replaced it last season after messing around failing to find a fix for the old one. Easy to replace and well worth it.

08-14-2015, 09:33 PM
It does have some play in it up and down. .... where did you find a replacement?

Sent from my SCH-I545 using Tapatalk

08-14-2015, 09:44 PM
Original tilt helm part no.9151018 Teleflex (seastar solutions) was used on my boat, I replaced it with SH91810P

found mine on ebay. Its an easy swap

08-14-2015, 09:48 PM
found the thread


08-15-2015, 08:16 AM
We had a similar problem/sound with my brother in laws 05 Malibu response. We changed his out because there was just too much play in the wheel and the tilt. Replaced it all.... tilt, pinion and rack/steering cable. Boat handles like new and is dead silent now. Great upgrade and worth the time.