PDA

View Full Version : trailor wiring Help!


wakes
08-17-2011, 11:13 AM
I replaced my trailor connector spliced the correct colors but when I put my left blinker on both rear lights flash on and off and my right side marker amber and red do not work. Any suggestions?
Thanks

tommcat
08-17-2011, 11:15 AM
Check to be sure you have a GOOD ground first. then recheck your wiring from the truck.
left turn=yellow
right turn=green
parking lamps=brown
ground=white(sometimes black)

TxsRiverRat
08-17-2011, 11:19 AM
I replaced my trailor connector spliced the correct colors but when I put my left blinker on both rear lights flash on and off and my right side marker amber and red do not work. Any suggestions?
Thanks


1st of all, why did you have to splice anything? I had similar issues and the solution was a new pigtail between the trailer and the truck.

blinker issue: that’s a ground issue...

the right side marker not working could be part of that issue or the wire has come loose.

wakes
08-18-2011, 01:06 AM
Thanks my connector was totally corroded

oldairboater
08-18-2011, 10:56 AM
All splices in wiring on trailers are potential problems eventually. If you must splice make sure the trailer was wired properly to begin with. Make as few splices as possible and seal your splices. Make good splices. A splice that oxidizes or is loose is resistance and a problem. All grounds must be good. The vehicle must be wired right.

wakes
08-18-2011, 11:37 AM
Thank you I will do that

Lars
08-25-2011, 01:25 PM
yes yes, what he said.
If you can, solder the two wires together and then seal with liquid tape. This will give you the best and strongest connection.

Skipper
08-25-2011, 10:37 PM
Isolate each wire and check for shorting. Usually occurs at the tongue where the wires get pinched by the safety cables. Also look where the wires exit the trailer.