PDA

View Full Version : 2011 X-15 Ballast Questions


shwapx15
08-08-2011, 04:19 PM
I just purchased a 2011 x15 and I am new to the whole ballast procedure so if someone could help me out that would be greatly appreciated!

When filling/emptying the ballast, it says the engine must be at 1500 rpm... can you be standing still (neutral with engine revving at 1500 rpm) or do you have to be moving?

Does the ballast tank empty and fill from the same hole on the bottom of the boat?

The owner’s manual says that a red light on top of ballast toggle switches should blink 6 times when tank is full… this doesn’t seem to be working... so should I watch the overflow hole on the side of the boat to see when tank is full?

Is there an automatic shut-off mechanism when emptying the ballast tanks?

Thanks alot!

Trig2275
08-08-2011, 05:10 PM
I rev to 1500rpm in neutral when filling and just drive forward when emptying. I don't use the BIG to control my ballast. I just use the switches manually. When they over flow out the sides I turn them off. They are on timers though if you forget to turn them off.

lawdogg149
08-08-2011, 08:17 PM
I do the same. watch for water coming out the sides. Listen for pumps when empty.

UrbantuxTN
08-08-2011, 09:15 PM
I just watch the water coming out on my x15, none of the lights work on my ballast switches.

ryfly161
08-10-2011, 04:23 PM
The big system is nice when you are changing out riders that are at different levels, just put it in neutral and let the big system fill or remove water as needed, you can do it on the move if you are reseting where you are int your cove or while the next rider is getting ready but it is only really worth it if you have people with different skill levels to let the big systems do it otherwise just fill it all the way and go big or go home.

gerbzguy
09-13-2011, 03:17 AM
I wait for the water to come out also. My switch lights are hit or miss and my port side indicator on my BIG display does not appear...

GoneBoatN
09-13-2011, 02:26 PM
This is what I have discovered about ballast fill fill via the BIG.

The ballast fill via the rider settings is based upon time and not the %full of the tank that you will see on the BIG screen. I had an issue where the I set the fill to 50% and it was filling way past that. The dealer service mechanic (good guy) and MC via the dealer were stumbling around figuring out how to correct. The mechanic mentioned that he was told by MC the ballast ran via timer. If you read other posts about ballast you will read how you can adjust the timers - this appears not to be how you do it for systems equiped with BIG. On the BIG, go into System Setup and you will find Ballast Configuration where you can adjust the fill and empty times. I simply lowered my value until the pump ran for the period of time where it hit the % full I had for the rider setting. I feel this will not be the most accurate (running based upon time) but at least I now understand how it works.

I have an 2010 X-15, I don't know how much this applies to others so your mileage may vary.

Will.I.am
09-15-2011, 09:19 PM
It also states that 1500 RPM and moving. All the RPM increase does is charge the battery and give good current to the pump motors. It is the moving in the water that gives a little push to the water.

I have the x-15 (2011) and just listen to the motors & see water over the side. The blinking lights are useless. When emptying, you can hear the motors get loud and you will also hear "bubbles" from under the boat.

I have filled / emptied the boat numerous time without the motor running.

Nordicron
09-12-2013, 12:57 PM
On my buddies 2010 x-15 unless he has the boat started and in a high idle the pumps will constantly shut off when draining or filling. He says it has to do with the pumps having voltage or current detectors and they auto shutoff because the alternator isn't spinning high enough making the pumps think the tank is empty or full. Seems like a weird design to me. Is this the case?

Stefan
09-12-2013, 01:36 PM
I have a 2012 X-15 but I only have the engine running when filling ballast (about 2500lbs total when surfing) if I need to get somewhere and I've never had battery problems, I personally think it just increases your hours if you fill ballast with the engine running...

Aric'sX15
09-12-2013, 04:36 PM
On my buddies 2010 x-15 unless he has the boat started and in a high idle the pumps will constantly shut off when draining or filling. He says it has to do with the pumps having voltage or current detectors and they auto shutoff because the alternator isn't spinning high enough making the pumps think the tank is empty or full. Seems like a weird design to me. Is this the case?

nope. i literally never ran my rmps up if i was filling up the ballast, sometimes emptied on my lift with the boat off. That shouldnt happen unless the impellers are bad, or his batteries are bad.

MattsCraft
09-12-2013, 05:33 PM
You can fill and empty without the engine running, however you can fiscally here the pumps change rpm's when you increase the engine rpm to about 1500. This makes the pumps run at optimum, making them more efficient thus reducing wear on the impellers.

Filling while still and empty while in motion will also improve your time accuracy of the system.

My fill time for the rears with 600lbs overflow bags is 8 minutes fill and 8.5 minutes empty. KGB is 6 and 6.5 respectively.

Your call.

Nordicron
09-13-2013, 08:01 AM
I don't know maybe it is his batteries but again no way that he can fill or empty if his boat is off. Even with it on just idling the pumps will constantly shut off. Like I said if the boat isn't bumped to high idle your constantly looking over at the switch to see if it is flashing or not. Forget about trying to do anything with the ballast if the boat isn't started. I think it's a cool feature to save wear and tear on impellers but seems like there could be a better way for the system to sense when the tanks are empty or full. Like a water sensor in the over flow and one in the intake.

I was just posting to find out if others see this problem and what are some solutions? Any settings that can be changed or adjusted?

jkcTN
09-13-2013, 08:54 AM
I have an 07 X-15 and I rarely ever fill with the engine running. I always pull to my spot turn the engine off flip the ballast switches and let them fill while I hook the rope up and get ready. The water comes out the over flow before the timer shuts them off every time.

Sent from my Z10 using Tapatalk 2