PDA

View Full Version : Ballast again


76S&S
08-05-2011, 02:18 PM
After reading through numerous ballast threads, I haven't found a solution for my issue.

I've already replace the pump and impellor. My KGB (center) bag will fill but not empty. I can blow through all lines, so nothing is clogged. If I disconnect the fill/drain line from the KGB at the pump, water will drain on it's own, but if I try to pump it out, nothing.:confused::confused:

G-Star
08-05-2011, 02:37 PM
Is your ballast totally stock, or have you added/changed anything?

76S&S
08-05-2011, 03:42 PM
Not stock but have been running it this way for a year or more.

The overflow from the KGB goes into a second bag in the bow. The additional bag then overflows out of the stock overflow thru hulls. When draining, the bow bag, "gravity" feeds the KGB, to the pump, then out the drain. Currently both, KGB and bow bag are full. I can blow through the KGB line at the pump and air comes out the overflow, so there are no obstructions in the plumbing.

kskonn
08-05-2011, 03:46 PM
Are you able to get a vacum on it so that the pump can pull water from the bag?

G-Star
08-05-2011, 03:47 PM
Does the bow bag (IBS?) empty, but not the KGB? or does neither empty?

vision
08-05-2011, 03:47 PM
Sorry I do not know all that you have already done so I maybe suggesting something you have already tried, but:

1. Have you replaced the impeller in the KGB pump. Pumping one way but not the other can be a sign of a bad impeller (not flipping correctly). If the impeller looks ok, try greasing the interior housing.

2. By all lines, do you also mean the over flow/vent line as well? If you pour fluid into the vent for the KGB does it easy make it to the sac?

3. Is there a lot of air in your KGB preventing the pump from priming (or is the line from the pump to the sac connected to the incorrect fitting, i.e to the top and not the bottom).

4. Lastly, if you switch pumps temporarily does it work (ruling out pump versus lines).

kskonn
08-05-2011, 03:48 PM
My money is on priming, I have seen this before when extra bags are added.

76S&S
08-05-2011, 03:55 PM
Are you able to get a vacum on it so that the pump can pull water from the bag?

Don't have vacum pump.

76S&S
08-05-2011, 03:58 PM
Sorry I do not know all that you have already done so I maybe suggesting something you have already tried, but:

1. Have you replaced the impeller in the KGB pump. Pumping one way but not the other can be a sign of a bad impeller (not flipping correctly). If the impeller looks ok, try greasing the interior housing. Replaced pump and impeller

2. By all lines, do you also mean the over flow/vent line as well? If you pour fluid into the vent for the KGB does it easy make it to the sac? yes

3. Is there a lot of air in your KGB preventing the pump from priming (or is the line from the pump to the sac connected to the incorrect fitting, i.e to the top and not the bottom). KGB is full as a tick of water

4. Lastly, if you switch pumps temporarily does it work (ruling out pump versus lines).I've tried two different pumps and impellers


This is not a new install, I've been running this way for quite a while, but all of the sudden it won't empty.

76S&S
08-05-2011, 04:00 PM
My money is on priming, I have seen this before when extra bags are added.

But...........if I simply disconnect the hose from the KGB at the pump, water starts flowing.....that is why I can't figure out why it won't pump.:confused:

76S&S
08-05-2011, 04:01 PM
Does the bow bag (IBS?) empty, but not the KGB? or does neither empty?

Neither empty

G-Star
08-05-2011, 04:08 PM
Neither empty

I'm suspecting the hose between the pump and the KGB, or the hose between the KGB and the bow bag. Check for partial kinks or weak/soft spots that would allow water to flow under positive pressure, but collapse/close off under suction.

76S&S
08-05-2011, 04:12 PM
I'm suspecting the hose between the pump and the KGB, or the hose between the KGB and the bow bag. Check for partial kinks or weak/soft spots that would allow water to flow under positive pressure, but collapse/close off under suction.

I'm thinking it may be collapsing under suction, thanks for the suggestion. I'll update the thread on Monday after I check it out this weekend.

G-Star
08-05-2011, 05:51 PM
No worries. Good luck to you.