PDA

View Full Version : WS-420 Wet Sounds EQ install


draegerd
07-28-2011, 09:56 AM
Just got a WS-420. Does anyone have any insight as to installing it? I plan to put it under the steering wheel area. Connecting to the amps doesn't sound TOO difficult.. But wiring it to power is where I'm unsure. Can anyone show me some pictures and tell me to what they wired the power, ground, and remote lead turn on to?

We have JL Audio MHD600/4 and HD900/5 amps that came in our X2.

Any advice would be greatly appreciated. I've never had to do much wiring and I don't want to mess this up.

CantRepeat
07-28-2011, 10:18 AM
Just got a WS-420. Does anyone have any insight as to installing it? I plan to put it under the steering wheel area. Connecting to the amps doesn't sound TOO difficult.. But wiring it to power is where I'm unsure. Can anyone show me some pictures and tell me to what they wired the power, ground, and remote lead turn on to?

We have JL Audio MHD600/4 and HD900/5 amps that came in our X2.

Any advice would be greatly appreciated. I've never had to do much wiring and I don't want to mess this up.

You can use the same ground, power as your head unit. The head unit also has a remote on wire that runs to your amps, use this wire.

draegerd
07-28-2011, 10:36 AM
Okay, So just to be certain, I'd find those just under the glovebox and would have to buy some wire to run from under the steering wheel? Will I have to splice the wires from the head unit for this?

draegerd
07-28-2011, 10:39 AM
Also, is there anything else I'll need to buy? I plan on getting 3 RCA cables and a new, longer AUX cable.
Guess I'll need to buy some 12 ga. wire and some connectors too? what else?