PDA

View Full Version : fuel gauge not working


mrm2083
07-25-2011, 06:19 PM
The fuel gauge on My 06 X2 only stays on empty. How can I test to see if it is the gauge, the sending unit, or wiring?

ps205
07-25-2011, 06:25 PM
I don't think there is a quick, easy way to tell if its the gauge, brainbox, or sender. Mine quit early this season and I just started from the simple and was going to work my way to the most expensive part....

1. Disconnect the wire at the sending unit and make sure its clean and in good shape, then reconnect and see if the gauge works.
2. Replace the sending unit with a new one and see if that solves the problem.. I would guess that one of these 2 will solve 95% of falures.
3. If its not #1 or #2 then you will need to make a call to take the boat to the dealer or not because the rest starts to get expensive if you guess wrong.

Good luck.

mrm2083
07-25-2011, 06:41 PM
Is there any way to just apply power to the gauge or something and bypass both the MDC and the sender?

mrm2083
07-26-2011, 11:42 AM
There are four wires the connect to the back of the gauge. Anyone know what each wire is for? Obviously black is ground but how about the other 3

agarabaghi
07-26-2011, 11:44 AM
Go to the fuel sender. Un plug it. 1 end is going to the mdc / gague 1 end goes to the fuel sender.

Short the wire going to the mdc / gauge, if the gauge works it will go to full when you short it.

mrm2083
07-26-2011, 10:32 PM
Ok I tried shorting it and the gauge did nothing. Does that mean it is for sure the gauge or could it be the MDC? Does the fact that all the other gauges work perfectly most likely rule out the MDC?

Go to the fuel sender. Un plug it. 1 end is going to the mdc / gague 1 end goes to the fuel sender.

Short the wire going to the mdc / gauge, if the gauge works it will go to full when you short it.

agarabaghi
07-26-2011, 10:44 PM
that i do not know, my fuel gauge went up so i said ok everything works.